aboutsummaryrefslogtreecommitdiffstats
path: root/community/libdbi-drivers
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-08-18 12:58:33 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-18 21:11:39 +0000
commitfad19051951129081c94d9ca641af6bbb1389e20 (patch)
tree4f6fac56923653086b9db2df0052a834b70b6966 /community/libdbi-drivers
parent5df6fbc76284929c44d2db7db6d12f675a91958c (diff)
downloadaports-fad19051951129081c94d9ca641af6bbb1389e20.tar.bz2
aports-fad19051951129081c94d9ca641af6bbb1389e20.tar.xz
testing/[various]: move to community
Moves the following packages to community after successful build and testing. bogofilter corebird fbpanel hermes libdbi-drivers luufs netsurf opencpn py-sensehat rng-tools volumeicon
Diffstat (limited to 'community/libdbi-drivers')
-rw-r--r--community/libdbi-drivers/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/libdbi-drivers/APKBUILD b/community/libdbi-drivers/APKBUILD
new file mode 100644
index 0000000000..b64ebfaf4e
--- /dev/null
+++ b/community/libdbi-drivers/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer:
+pkgname=libdbi-drivers
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="Provides the database-specific drivers for the libdbi framework"
+url="http://libdbi-drivers.sourceforge.net/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="libdbi-dev freetds-dev mysql-dev postgresql-dev sqlite-dev
+ $depends_dev"
+install=""
+subpackages=""
+options="libtool"
+source="http://downloads.sourceforge.net/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz"
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --localstatedir=/usr \
+ --with-mysql \
+ --with-pgsql \
+ --with-sqlite3 \
+ --disable-docs \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ chmod -R o-w "$pkgdir"/usr/lib/libdbi
+}
+
+md5sums="9f47b960e225eede2cdeaabf7d22f59f libdbi-drivers-0.9.0.tar.gz"
+sha256sums="43d2eacd573a4faff296fa925dd97fbf2aedbf1ae35c6263478210c61004c854 libdbi-drivers-0.9.0.tar.gz"
+sha512sums="f4d3aaa71014697c53012a10bf9f0af398bcf5ee5872af165f8f43a682d2fb3045a9172ffea0e068dcbfcad52494878c037d8d90fadfaf176936e42f7f1e85c1 libdbi-drivers-0.9.0.tar.gz"