aboutsummaryrefslogtreecommitdiffstats
path: root/community/libdmtx
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-01-06 10:10:31 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-06 10:35:58 +0100
commit78b24a19f4fef30701a92b4f30bd6669c239a988 (patch)
tree1d87a56f27e6e106bb0369d16038cd86cb2c098c /community/libdmtx
parent0db14c08aac01ae386c3147f77cc0f23ba27533c (diff)
downloadaports-78b24a19f4fef30701a92b4f30bd6669c239a988.tar.bz2
aports-78b24a19f4fef30701a92b4f30bd6669c239a988.tar.xz
community/libdmtx: move from testing
Diffstat (limited to 'community/libdmtx')
-rw-r--r--community/libdmtx/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/libdmtx/APKBUILD b/community/libdmtx/APKBUILD
new file mode 100644
index 0000000000..6efc006f5b
--- /dev/null
+++ b/community/libdmtx/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libdmtx
+pkgver=0.7.5
+pkgrel=0
+pkgdesc="A software for reading and writing Data Matrix 2D barcodes"
+url="https://libdmtx.sourceforge.net/"
+arch="all"
+license="BSD-2-Clause"
+makedepends="autoconf automake libtool"
+source="https://github.com/dmtx/libdmtx/archive/v$pkgver/libdmtx-$pkgver.tar.gz"
+subpackages="$pkgname-static $pkgname-dev $pkgname-libs $pkgname-doc"
+
+prepare() {
+ default_prepare
+
+ ./autogen.sh
+}
+
+build() {
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c4bccc9eff4a93b6bb417ed23ed46e82cc98b650a94be40479d192af8537ee02a16700fbbd8f2271035ff8b804c40ab6461825d94bd80a3081d3a4b3988ea22a libdmtx-0.7.5.tar.gz"