aboutsummaryrefslogtreecommitdiffstats
path: root/community/libdvdcss/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-27 07:55:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-29 15:55:32 +0000
commit3d69d14c425b8ae6bc28d5936cd602c0e5e977ab (patch)
tree886da516c972fad64b33f8482f563837b8d1589a /community/libdvdcss/APKBUILD
parentaaebd10e3a3225c2720dad72e6481c9646b2beb4 (diff)
downloadaports-3d69d14c425b8ae6bc28d5936cd602c0e5e977ab.tar.bz2
aports-3d69d14c425b8ae6bc28d5936cd602c0e5e977ab.tar.xz
community/libdvdcss: move from main
Diffstat (limited to 'community/libdvdcss/APKBUILD')
-rw-r--r--community/libdvdcss/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/libdvdcss/APKBUILD b/community/libdvdcss/APKBUILD
new file mode 100644
index 0000000000..62595018ea
--- /dev/null
+++ b/community/libdvdcss/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=libdvdcss
+pkgver=1.4.2
+pkgrel=0
+pkgdesc="Library for accessing DVDs like a block device without having to bother about the decryption"
+url="http://www.videolan.org/developers/libdvdcss.html"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="file linux-headers"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.videolan.org/pub/libdvdcss/$pkgver/libdvdcss-$pkgver.tar.bz2
+ replace-error.patch
+ "
+
+prepare() {
+ default_prepare
+}
+
+build() {
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ make check
+}
+
+sha512sums="e46ccded1951046ec481604c5b533c435be14cd0e734cd5315b61868836a20edf4cdc7c1466c2f4ed374de4382c5e758ace700e84aadcb29513001d696f1049c libdvdcss-1.4.2.tar.bz2
+6aa9510b662d39527935f90fc500d27a8ff6bfc45a967ee3b3affcb0637a3d9ce9acb0967e88c65711a74eeb2061c63b14c542ec47b1dded29a5729f7e659f8e replace-error.patch"