aboutsummaryrefslogtreecommitdiffstats
path: root/community/libetpan/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-08 04:27:49 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-14 11:28:32 +0000
commitece355c794df3630dde557a77765ee81dd95e3eb (patch)
treef9e1c35a30acf045242c8151731137cc6582812b /community/libetpan/APKBUILD
parent4d6fc46e0012ae40dbdc5fc96c6dda2dcc01746b (diff)
downloadaports-ece355c794df3630dde557a77765ee81dd95e3eb.tar.bz2
aports-ece355c794df3630dde557a77765ee81dd95e3eb.tar.xz
community/libetpan: move from main
Diffstat (limited to 'community/libetpan/APKBUILD')
-rw-r--r--community/libetpan/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/libetpan/APKBUILD b/community/libetpan/APKBUILD
new file mode 100644
index 0000000000..7c243b4e66
--- /dev/null
+++ b/community/libetpan/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libetpan
+pkgver=1.9.2
+pkgrel=0
+pkgdesc="a portable middleware for email access"
+url="http://www.etpan.org/"
+arch="all"
+license="custom:etpan"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="db-dev cyrus-sasl-dev curl-dev expat-dev gnutls-dev libgcrypt-dev
+ libgpg-error-dev autoconf automake libtool zlib-dev"
+depends_dev="cyrus-sasl-dev db-dev"
+source="libetpan-$pkgver.tar.gz::https://github.com/dinhviethoa/libetpan/archive/$pkgver.tar.gz
+ "
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ ./autogen.sh
+}
+
+build () {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-gnutls=yes \
+ --with-openssl=no \
+ --with-gnutls \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/license.txt
+}
+
+sha512sums="3e2e1de77fae2212374e909d15ed8564eee90883c38fee0ca69f58785733b1ac2df848da1bda6f55577d647e0ad27bc3057199e70b6ef01f2a7e2823b24113ba libetpan-1.9.2.tar.gz"