aboutsummaryrefslogtreecommitdiffstats
path: root/community/libfakekey
diff options
context:
space:
mode:
authorDaniele Debernardi <drebrez@gmail.com>2019-10-01 23:26:39 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-10-06 11:25:21 +0200
commitfbc5633c1ad3c695b9af0bdea71f6e55cc62f4e0 (patch)
tree04cca26688793bc0170be16d0dba04727aabe7ae /community/libfakekey
parent54b88d2c28b42276f6da2f9e155132fe6a0e4799 (diff)
downloadaports-fbc5633c1ad3c695b9af0bdea71f6e55cc62f4e0.tar.bz2
aports-fbc5633c1ad3c695b9af0bdea71f6e55cc62f4e0.tar.xz
community/libfakekey: move from testing
Diffstat (limited to 'community/libfakekey')
-rw-r--r--community/libfakekey/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/libfakekey/APKBUILD b/community/libfakekey/APKBUILD
new file mode 100644
index 0000000000..dd229bee23
--- /dev/null
+++ b/community/libfakekey/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Daniele Debernardi <drebrez@gmail.com>
+# Maintainer: Daniele Debernardi <drebrez@gmail.com>
+pkgname=libfakekey
+pkgver=0.3
+pkgrel=0
+pkgdesc="X virtual keyboard library"
+url="https://www.yoctoproject.org/software-item/matchbox/"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="autoconf automake libtool libxtst-dev"
+subpackages="$pkgname-dev"
+source="http://git.yoctoproject.org/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$pkgver.tar.gz"
+options="!check" # No test suite present
+
+prepare() {
+ default_prepare
+ autoreconf --install
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static
+ make AM_LDFLAGS=-lX11
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9c09007c6ab616095bdf69669cfdf0d176d44beaeb6b2a0fe8e310bb835d3f241ca7499dcb523c1eeeb24968ef908c1951f97352da419fc1bbb3883cb43dd963 libfakekey-0.3.tar.gz"