aboutsummaryrefslogtreecommitdiffstats
path: root/community/libfm
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-20 10:54:27 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-20 10:55:35 -0600
commit530725e9d2e6338b1ca13f7964b73b595e4406d5 (patch)
tree51a8a0a55318eb4da80fe5d250aaa87aed2d62ae /community/libfm
parentad1e7fcc90bc8cd3f50b84e64ea2f9ee21835549 (diff)
downloadaports-530725e9d2e6338b1ca13f7964b73b595e4406d5.tar.bz2
aports-530725e9d2e6338b1ca13f7964b73b595e4406d5.tar.xz
community/libfm: Modernise and fix issues
* Clarify GPL version in license= * Add test suite * Tabs instead of two spaces * Since intltool is required, message files are built; add -lang pkg * Update URL
Diffstat (limited to 'community/libfm')
-rw-r--r--community/libfm/APKBUILD44
1 files changed, 25 insertions, 19 deletions
diff --git a/community/libfm/APKBUILD b/community/libfm/APKBUILD
index a0be31dbff..1eda7a4763 100644
--- a/community/libfm/APKBUILD
+++ b/community/libfm/APKBUILD
@@ -3,32 +3,38 @@
pkgname=libfm
pkgver=1.2.5
-pkgrel=0
-pkgdesc='Library for file management'
-url='http://pcmanfm.sourceforge.net/'
-arch='all'
-license='GPL'
-makedepends='gtk+2.0-dev menu-cache-dev udisks-dev intltool dbus-glib-dev
- libexif-dev'
-options='libtool'
-subpackages="$pkgname-dev $pkgname-doc"
+pkgrel=1
+pkgdesc="Library for file management"
+url="https://wiki.lxde.org/en/PCManFM"
+arch="all"
+license="GPL-2.0+"
+makedepends="gtk+2.0-dev menu-cache-dev udisks-dev intltool dbus-glib-dev
+ libexif-dev"
+options="libtool"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://downloads.sourceforge.net/pcmanfm/$pkgname-$pkgver.tar.xz"
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --enable-udisks \
- --with-gnu-ld || return 1
- make LDFLAGS+=' -lgobject-2.0 -lglib-2.0' || return 1
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-udisks \
+ --with-gnu-ld
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
- rm -rf "$pkgdir"/usr/include/libfm
- mv "$pkgdir"/usr/include/libfm-1.0/ "$pkgdir"/usr/include/libfm
+ rm -rf "$pkgdir"/usr/include/libfm
+ mv "$pkgdir"/usr/include/libfm-1.0/ "$pkgdir"/usr/include/libfm
}
md5sums="a1ba9ae5e920f38b647dd511edd6c807 libfm-1.2.5.tar.xz"