aboutsummaryrefslogtreecommitdiffstats
path: root/community/libfm
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-12-23 00:44:58 +0300
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-07 15:45:38 +0000
commit54cfe168b93e74e8495f5bfaec1e853fd4ba4360 (patch)
treef039db834652ed44c1528f658501614060038976 /community/libfm
parent36da800f28cabab13e2fc5306c94f4839d05678a (diff)
downloadaports-54cfe168b93e74e8495f5bfaec1e853fd4ba4360.tar.bz2
aports-54cfe168b93e74e8495f5bfaec1e853fd4ba4360.tar.xz
community/{libfm,pcmanfm}: Upgrade to 1.3.1
Diffstat (limited to 'community/libfm')
-rw-r--r--community/libfm/APKBUILD26
-rw-r--r--community/libfm/undef-G_DISABLE_ASSERT-earlier.patch17
2 files changed, 18 insertions, 25 deletions
diff --git a/community/libfm/APKBUILD b/community/libfm/APKBUILD
index 2b08a417c1..9808dcb1d5 100644
--- a/community/libfm/APKBUILD
+++ b/community/libfm/APKBUILD
@@ -2,18 +2,29 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
pkgname=libfm
-pkgver=1.3.0.2
-pkgrel=1
+pkgver=1.3.1
+pkgrel=0
pkgdesc="Library for file management"
url="https://wiki.lxde.org/en/PCManFM"
arch="all"
license="GPL-2.0-or-later"
-makedepends="gtk+2.0-dev menu-cache-dev udisks-dev intltool dbus-glib-dev
- libexif-dev vala gtk-doc automake autoconf libtool"
+makedepends="
+ autoconf
+ automake
+ dbus-glib-dev
+ gtk+2.0-dev
+ gtk-doc
+ intltool
+ libexif-dev
+ libtool
+ menu-cache-dev
+ udisks-dev
+ vala
+ "
options="libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="$pkgname-$pkgver.tar.gz::https://github.com/lxde/$pkgname/archive/$pkgver.tar.gz
- undef-G_DISABLE_ASSERT-earlier.patch
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/lxde/libfm/archive/$pkgver.tar.gz
"
prepare() {
default_prepare
@@ -44,5 +55,4 @@ package() {
mv "$pkgdir"/usr/include/libfm-1.0/ "$pkgdir"/usr/include/libfm
}
-sha512sums="c954c7210b6eee66ec265490e16fe91fe7995cd95b340f49197eec60a9af94f1ca0f67861dd5455c0deb81a10f5091cbf3dc471ed224477acdc081b48d036c69 libfm-1.3.0.2.tar.gz
-3bc242566402455a1e0c66e9b7962ddf92a4113a49e9e094e5d585b00649327352e45917f229606b7edfc35e9ba3a9ae8733457de5ca682e1ab7fdd869bcd03a undef-G_DISABLE_ASSERT-earlier.patch"
+sha512sums="82bbcb1b9c7d4543bcb075906bdc1554462b041ad936e2f0334ae478302b19808cdbfe6d0c86a039bbd72a2491f2d2ada61a324fe3933a8dde16a03d93bef2bc libfm-1.3.1.tar.gz"
diff --git a/community/libfm/undef-G_DISABLE_ASSERT-earlier.patch b/community/libfm/undef-G_DISABLE_ASSERT-earlier.patch
deleted file mode 100644
index 34bd7d0418..0000000000
--- a/community/libfm/undef-G_DISABLE_ASSERT-earlier.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/src/tests/test-fm-path.c
-+++ b/src/tests/test-fm-path.c
-@@ -19,12 +19,12 @@
- * MA 02110-1301, USA.
- */
-
--#include <fm.h>
--
- //ignore for test disabled asserts
- #ifdef G_DISABLE_ASSERT
- #undef G_DISABLE_ASSERT
- #endif
-+
-+#include <fm.h>
-
- #define TEST_PARSING(func, str_to_parse, ...) \
- G_STMT_START { \