aboutsummaryrefslogtreecommitdiffstats
path: root/community/libfm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-03-07 09:51:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-03-07 09:51:58 +0000
commit64c79244d93984662eec44327bf750f641374d09 (patch)
treee9f8a697999b010800e9dc1d0e20ba1485d5dfc1 /community/libfm
parent22341f0b60770df90cb1e6e174ad916daca84227 (diff)
downloadaports-64c79244d93984662eec44327bf750f641374d09.tar.bz2
aports-64c79244d93984662eec44327bf750f641374d09.tar.xz
community/pcmanfm: move from main
Diffstat (limited to 'community/libfm')
-rw-r--r--community/libfm/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/libfm/APKBUILD b/community/libfm/APKBUILD
new file mode 100644
index 0000000000..1e91cc7dfb
--- /dev/null
+++ b/community/libfm/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Łukasz Jendrysik <scadu@yandex.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=libfm
+pkgver=1.2.4
+pkgrel=0
+pkgdesc='Library for file management'
+url='http://pcmanfm.sourceforge.net/'
+arch='all'
+license='GPL'
+makedepends='gtk+2.0-dev menu-cache-dev udisks-dev intltool dbus-glib-dev
+ libexif-dev'
+options='libtool'
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/pcmanfm/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-udisks \
+ --with-gnu-ld || return 1
+ make LDFLAGS+=' -lgobject-2.0 -lglib-2.0' || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+
+ rm -rf "$pkgdir"/usr/include/libfm
+ mv "$pkgdir"/usr/include/libfm-1.0/ "$pkgdir"/usr/include/libfm
+}
+
+md5sums="74997d75e7e87dc73398746fd373bf52 libfm-1.2.4.tar.xz"
+sha256sums="7804f6f28cb3d1bc8ffb3151ab7ff0c063b27c5f9b06c682eb903e01cf25502f libfm-1.2.4.tar.xz"
+sha512sums="c609e822959f9fa83eaee6552906b6fd22d210f0802944816230b1932fc06632dc557b8998d2d065100212f79dffe13257587c744aba78592983681c8410dc24 libfm-1.2.4.tar.xz"