aboutsummaryrefslogtreecommitdiffstats
path: root/community/libfreehand
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 07:54:46 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 12:52:04 +0000
commit632ea158157084ba82e87683c87937437c237496 (patch)
treed18b664af41e480bb79c77d03324613826cc098e /community/libfreehand
parent36678de208f015aa651e1f77c16fce9e675db98e (diff)
downloadaports-632ea158157084ba82e87683c87937437c237496.tar.bz2
aports-632ea158157084ba82e87683c87937437c237496.tar.xz
community/libfreehand: moved from main
Diffstat (limited to 'community/libfreehand')
-rw-r--r--community/libfreehand/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/community/libfreehand/APKBUILD b/community/libfreehand/APKBUILD
new file mode 100644
index 0000000000..13ba3ac1f2
--- /dev/null
+++ b/community/libfreehand/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=libfreehand
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Import filter and tools for Adobe FreeHand documents"
+url="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand"
+arch="all"
+license="MPL2"
+depends=""
+depends_dev="librevenge-dev libxml2-dev zlib-dev"
+makedepends="$depends_dev gperf perl doxygen"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+tools() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+md5sums="f50cee10fd59d50f1f350f9e817a0ab3 libfreehand-0.1.0.tar.xz"
+sha256sums="5119aac8b0b28d749905f8094e526b9a018a2e4a208b5d0317c7554a62af4706 libfreehand-0.1.0.tar.xz"
+sha512sums="8b3bdd3df158d4371f5007abaa5fd11f7039e0f3e2bbef9540b730ca3fcf94cbf6bd50a8bf917c948fb5257f1b0704b2a10b7cb49b1becdedfef52b41a826f90 libfreehand-0.1.0.tar.xz"