aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgdata/only-ipv4-tests.patch
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-11 12:31:58 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 15:18:54 +0000
commitb4d01daa0a5f345aeb990551278b0efd89e94d8e (patch)
tree95df2b247be81f338a873020f636e4dfc4fa3b45 /community/libgdata/only-ipv4-tests.patch
parent13129b99661d439847296d2609e361ccda81e0b4 (diff)
downloadaports-b4d01daa0a5f345aeb990551278b0efd89e94d8e.tar.bz2
aports-b4d01daa0a5f345aeb990551278b0efd89e94d8e.tar.xz
community/libgdata: enable GOA and GNOME integration, required for gvfs
* Modernize APKBUILD * Adopt package * Fix URL&License Closes GH-7597
Diffstat (limited to 'community/libgdata/only-ipv4-tests.patch')
-rw-r--r--community/libgdata/only-ipv4-tests.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/libgdata/only-ipv4-tests.patch b/community/libgdata/only-ipv4-tests.patch
new file mode 100644
index 0000000000..acbb00c1c4
--- /dev/null
+++ b/community/libgdata/only-ipv4-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/gdata/tests/streams.c b/gdata/tests/streams.c
+index 7158754..1763bd9 100644
+--- a/gdata/tests/streams.c
++++ b/gdata/tests/streams.c
+@@ -193,7 +193,7 @@ create_server (SoupServerCallback callback, gpointer user_data, GMainLoop **main
+ g_main_context_push_thread_default (context);
+
+ soup_server_listen_local (server, 0 /* random port */,
+- SOUP_SERVER_LISTEN_HTTPS, &error);
++ SOUP_SERVER_LISTEN_HTTPS | SOUP_SERVER_LISTEN_IPV4_ONLY, &error);
+ g_assert_no_error (error);
+
+ g_main_context_pop_thread_default (context);