aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgit2-0.27
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-23 05:17:10 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-23 05:20:36 +0000
commit35c4fd0f021249f857f92a2daf3dde95bb2226b3 (patch)
tree26f7b2d528fc520fe37a27112d651cc0d4f79cc2 /community/libgit2-0.27
parentc7c6a2b9a25610fe5d54fbb362807bcb0c3a3ae5 (diff)
downloadaports-35c4fd0f021249f857f92a2daf3dde95bb2226b3.tar.bz2
aports-35c4fd0f021249f857f92a2daf3dde95bb2226b3.tar.xz
community/libgit2-0.27: temp aport
This aport is needed to rebuild rust against new libgit2
Diffstat (limited to 'community/libgit2-0.27')
-rw-r--r--community/libgit2-0.27/APKBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/community/libgit2-0.27/APKBUILD b/community/libgit2-0.27/APKBUILD
new file mode 100644
index 0000000000..dba4bbe53b
--- /dev/null
+++ b/community/libgit2-0.27/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Pierre-Gilas MILLON <pgmillon@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libgit2-0.27
+_pkgname=libgit2
+pkgver=0.27.8
+pkgrel=0
+pkgdesc="A linkable library for Git"
+url="https://libgit2.org/"
+arch="all"
+license="GPL-2.0-only-WITH-GCC-exception-2.0"
+depends_dev="curl-dev libssh2-dev"
+makedepends="$depends_dev python2 cmake zlib-dev openssl-dev"
+subpackages="$pkgname-dev $pkgname-tests::noarch"
+provides="$pkgname-libs" # for backward compatibility with v3.4
+replaces="$pkgname-libs" # for backward compatibility with v3.4
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.tar.gz
+ "
+options="!check" # FIXME some tests fails
+builddir="$srcdir/$_pkgname-$pkgver"
+
+# secfixes:
+# 0.27.4-r0:
+# - CVE-2018-15501
+# 0.27.3-r0:
+# - CVE-2018-10887
+# - CVE-2018-10888
+# 0.25.1-r0:
+# - CVE-2016-10128
+# - CVE-2016-10129
+# - CVE-2016-10130
+# 0.24.3-r0:
+# - CVE-2016-8568
+# - CVE-2016-8569
+
+build() {
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS="$CFLAGS"
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ make test
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+tests() {
+ pkgdesc="$pkgdesc (tests)"
+
+ mkdir -p "$subpkgdir"/usr/src/$pkgname/
+ cp -a "$builddir"/tests "$subpkgdir"/usr/src/$pkgname/
+}
+
+sha512sums="53ab69a0687afd315029fdbe0ce8192b7e88f7f1ff6bc9c4875718e638cecd64755a9942ad605e6c388c58c6b892b351d54c5405de8e0d5ba90406055a25ffaa libgit2-0.27-0.27.8.tar.gz"