aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgit2-glib/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-30 14:54:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-07 10:13:47 +0100
commit78d37d9942be8548da47259a8b0f5ea584ed1f16 (patch)
treec071a4c1c2581c76002b213923520dff8a2f90d1 /community/libgit2-glib/APKBUILD
parent92116a4678aa9557f35ec994424bb86ce1e21626 (diff)
downloadaports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.bz2
aports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.xz
tree-wide: use --buildtype=debugoptimized for meson packages
As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
Diffstat (limited to 'community/libgit2-glib/APKBUILD')
-rw-r--r--community/libgit2-glib/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/libgit2-glib/APKBUILD b/community/libgit2-glib/APKBUILD
index 16f42e850e..beac73f076 100644
--- a/community/libgit2-glib/APKBUILD
+++ b/community/libgit2-glib/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=libgit2-glib
pkgver=0.28.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Glib wrapper library around libgit2"
url="https://wiki.gnome.org/Projects/Libgit2-glib"
arch="all"
@@ -16,7 +16,7 @@ source="https://download.gnome.org/sources/libgit2-glib/${pkgver%.*.*}/libgit2-g
build() {
meson \
--prefix=/usr \
- --buildtype=release \
+ --buildtype=debugoptimized \
. output
ninja -C output
}