aboutsummaryrefslogtreecommitdiffstats
path: root/community/libhtp
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-11 20:01:31 +0200
committerprspkt <prspkt@protonmail.com>2019-03-11 20:15:50 +0200
commit01582b1f392cb983dacb868395a446a8f116ed26 (patch)
tree45e0f6d877fe2d51c4f7d848f2499dfd7d9f3451 /community/libhtp
parent7c360e98e08b155db68bdedf7a35c4c85691d8d8 (diff)
downloadaports-01582b1f392cb983dacb868395a446a8f116ed26.tar.bz2
aports-01582b1f392cb983dacb868395a446a8f116ed26.tar.xz
community/libhtp: add prepare function, move autoreconf
Diffstat (limited to 'community/libhtp')
-rw-r--r--community/libhtp/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/libhtp/APKBUILD b/community/libhtp/APKBUILD
index bc758f50d6..a62bfa95b5 100644
--- a/community/libhtp/APKBUILD
+++ b/community/libhtp/APKBUILD
@@ -12,9 +12,14 @@ makedepends="$depends_dev automake autoconf libtool"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/OISF/libhtp/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
build() {
cd "$builddir"
- autoreconf -vif
./configure \
--build=$CBUILD \
--host=$CHOST \