aboutsummaryrefslogtreecommitdiffstats
path: root/community/libidl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 15:52:36 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 19:24:01 +0000
commit90088e4eb6c202194d9e09cb0f3cbbd065e54dfe (patch)
treeae515e16f1fc1708f9810e9e2f2a2d730d3072c1 /community/libidl
parent97e2fae0c3d8573dd0bb250a5bb01262b3b62568 (diff)
downloadaports-90088e4eb6c202194d9e09cb0f3cbbd065e54dfe.tar.bz2
aports-90088e4eb6c202194d9e09cb0f3cbbd065e54dfe.tar.xz
community/libidl: move from main
Diffstat (limited to 'community/libidl')
-rw-r--r--community/libidl/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/libidl/APKBUILD b/community/libidl/APKBUILD
new file mode 100644
index 0000000000..24650de7f3
--- /dev/null
+++ b/community/libidl/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor:
+# Maintainer:
+pkgname=libidl
+pkgver=0.8.14
+pkgrel=2
+pkgdesc="Library for parsing Interface Definition Language files"
+url="https://www.gnome.org/"
+arch="all"
+options="!check" # No test suite.
+license="LGPL-2.0+"
+depends=
+makedepends="glib-dev flex bison"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/libIDL/${pkgver%.*}/libIDL-$pkgver.tar.bz2"
+
+builddir="$srcdir"/libIDL-$pkgver
+
+prepare() {
+ cd "$builddir"
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="906dde087908acd64b209fe466a89ae52a6ea23601cb30092063a6e062b1b6640fc2d5f422efcdd52b2b36ce20e6c244da6205fde0bdcec787fe64058be7adac libIDL-0.8.14.tar.bz2"