aboutsummaryrefslogtreecommitdiffstats
path: root/community/libixion
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-01-30 21:43:03 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-31 16:40:59 +0100
commit021ee053382c19a4de58c2554476894717cdd6de (patch)
tree830d993dd8fd0346f4b9d765cd587e0ab2af2aec /community/libixion
parent11568349c23f5f2aa1c85e74466d9b8ccc19ad20 (diff)
downloadaports-021ee053382c19a4de58c2554476894717cdd6de.tar.bz2
aports-021ee053382c19a4de58c2554476894717cdd6de.tar.xz
community/libixion: upgrade to 0.15.0
Diffstat (limited to 'community/libixion')
-rw-r--r--community/libixion/APKBUILD22
-rw-r--r--community/libixion/fix-nullptr_t.patch25
2 files changed, 34 insertions, 13 deletions
diff --git a/community/libixion/APKBUILD b/community/libixion/APKBUILD
index 1cfd88ff5c..8e3bde54a4 100644
--- a/community/libixion/APKBUILD
+++ b/community/libixion/APKBUILD
@@ -1,22 +1,19 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libixion
-pkgver=0.14.1
-pkgrel=3
-pkgdesc="a general purpose formula parser & interpreter"
+pkgver=0.15.0
+pkgrel=0
+pkgdesc="A general purpose formula parser & interpreter"
url="https://gitlab.com/ixion/ixion"
arch="all"
license="MPL-2.0"
-depends=""
-depends_dev=""
-makedepends="$depends_dev boost-dev mdds-dev"
-install=""
+makedepends="$depends_dev boost-dev mdds-dev spdlog-dev"
subpackages="$pkgname-dev"
-source="https://kohei.us/files/ixion/src/libixion-$pkgver.tar.xz"
-builddir="$srcdir/libixion-$pkgver"
+source="https://kohei.us/files/ixion/src/libixion-$pkgver.tar.xz
+ fix-nullptr_t.patch
+ "
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,15 +26,14 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
dev() {
default_dev
- cd "$builddir"
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="e4ae6348833d2178c1dc76916937bcc9d7821dc6570fe13093c441ca22e0301a1ca6a4cf85d9814b83534733dba98f4c4a372791f93bc57173317657675b9ae3 libixion-0.14.1.tar.xz"
+sha512sums="feecaa4a8e6191649a7ecbc6c0f4d7db6dba3a5e4a031c1f55236907bf94e2ece9ee05d18ed345e3503cffb4a380b04f6c4941ef4214ddf92687998a070b7543 libixion-0.15.0.tar.xz
+bd8c1a3159e57f315e10d44e0e2f1a28f7022485ced3603fdd0ff223cac8cfb2bb135e6e6c0d5ec5a99595c27a8c1c3948ad92d2f383dd90c6922964afd1136d fix-nullptr_t.patch"
diff --git a/community/libixion/fix-nullptr_t.patch b/community/libixion/fix-nullptr_t.patch
new file mode 100644
index 0000000000..b7ab049894
--- /dev/null
+++ b/community/libixion/fix-nullptr_t.patch
@@ -0,0 +1,25 @@
+From a8fe2c542b16ee30723ab3d7f3b643ee479e9723 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 23 Aug 2019 08:50:28 -0700
+Subject: [PATCH] Fix build with clang.
+
+---
+ include/ixion/model_context.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/ixion/model_context.hpp b/include/ixion/model_context.hpp
+index 6ff5b67..dc27ed0 100644
+--- a/include/ixion/model_context.hpp
++++ b/include/ixion/model_context.hpp
+@@ -61,7 +61,7 @@ public:
+ } value;
+
+ /** Initializes the cell to be empty. */
+- input_cell(nullptr_t);
++ input_cell(std::nullptr_t);
+ /** Boolean cell value. */
+ input_cell(bool b);
+ /** The char array must be null-terminated. */
+--
+2.24.1
+