aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkcddb
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-12 14:02:21 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 10:48:38 -0300
commit68c0b01b2db6e614ee9f9fee0fc660e027d525c7 (patch)
tree5ea8e3dce040ad88b811ca7a23a9695e40d7910f /community/libkcddb
parentc3e2656b8c8b9673a5e52b8eafe79e926e78201e (diff)
downloadaports-68c0b01b2db6e614ee9f9fee0fc660e027d525c7.tar.bz2
aports-68c0b01b2db6e614ee9f9fee0fc660e027d525c7.tar.xz
community/libkcddb: move from testing
Diffstat (limited to 'community/libkcddb')
-rw-r--r--community/libkcddb/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/libkcddb/APKBUILD b/community/libkcddb/APKBUILD
new file mode 100644
index 0000000000..337b8604c6
--- /dev/null
+++ b/community/libkcddb/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libkcddb
+pkgver=19.08.2
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/multimedia/"
+pkgdesc="KDE CDDB library"
+license="LGPL-2.0-or-later AND GPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kconfig-dev kdoctools-dev kcodecs-dev ki18n-dev kio-dev kwidgetsaddons-dev libmusicbrainz-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/libkcddb-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=ON
+ make
+}
+
+check() {
+ cd "$builddir"/build
+
+ # musicbrainztest-severaldiscs is broken
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "musicbrainztest-severaldiscs"
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="b19685387233bc845bce7be8a5a8a89ae1339b12a8ea64146da95159e3257b9ce387c53f537673aac048f64c4fd08b76988f2d57ee019102ca60795aa754011d libkcddb-19.08.2.tar.xz"