aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkcompactdisc
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-12 14:03:34 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 10:48:38 -0300
commit0d70c9ca5781eee1e5ef6f881cce997b78621d24 (patch)
tree15251e514a4ad48c4446969c07e7aae86c86ae6d /community/libkcompactdisc
parent68c0b01b2db6e614ee9f9fee0fc660e027d525c7 (diff)
downloadaports-0d70c9ca5781eee1e5ef6f881cce997b78621d24.tar.bz2
aports-0d70c9ca5781eee1e5ef6f881cce997b78621d24.tar.xz
community/libkcompactdisc: move from testing
Diffstat (limited to 'community/libkcompactdisc')
-rw-r--r--community/libkcompactdisc/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/libkcompactdisc/APKBUILD b/community/libkcompactdisc/APKBUILD
new file mode 100644
index 0000000000..1806a5973a
--- /dev/null
+++ b/community/libkcompactdisc/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libkcompactdisc
+pkgver=19.08.2
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/multimedia/"
+pkgdesc="Library for interfacing with CDs"
+license="GPL-2.0-or-later AND LGPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kcoreaddons-dev solid-dev ki18n-dev phonon-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/libkcompactdisc-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+options="!check" # No tests
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="4113e1fec72b4a1b4a054354dee8daf3ef1115b9f986581faadea4326cde2d7f9d153a34601151627d52b7ecd56a360772ad0e8869b992596ebdd7e5d8da014f libkcompactdisc-19.08.2.tar.xz"