aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmaa/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 15:53:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 19:24:08 +0000
commit25ae3c33664fbacb978c5f23a2ab12024c089ebd (patch)
treeeddf4366e14fb4e68d9ab4c464ac3544d41e74a5 /community/libmaa/APKBUILD
parent0dd3e84a40ac335b3746aa5b7d7c8712f3b2fb8b (diff)
downloadaports-25ae3c33664fbacb978c5f23a2ab12024c089ebd.tar.bz2
aports-25ae3c33664fbacb978c5f23a2ab12024c089ebd.tar.xz
community/libmaa: move from main
Diffstat (limited to 'community/libmaa/APKBUILD')
-rw-r--r--community/libmaa/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/libmaa/APKBUILD b/community/libmaa/APKBUILD
new file mode 100644
index 0000000000..90237a15e2
--- /dev/null
+++ b/community/libmaa/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=libmaa
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="Provides many low-level data structures which are helpful for writing compilers"
+url="https://sourceforge.net/projects/dict/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="libtool perl flex"
+install=""
+subpackages="$pkgname-dev"
+source="https://downloads.sourceforge.net/dict/${pkgname}-${pkgver}.tar.gz
+ fix-ppc64le-build-snprinf-buflen.patch"
+options="libtool"
+
+builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ cd "$builddir"
+ update_config_guess || return 1
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+sha512sums="dde91e8bf1c08515ff4662282d16a03b18a1dfb16eb7b95be980ba398ed1e65d8cd88e58d454e03a03f48a5ecca8bf23b4ebaf475a98630a9178318c12a1b176 libmaa-1.3.2.tar.gz
+8efab0163bbdb0e16cc4914779cddccd53b6107c0ddc5b8c370e408f837d6ababd490e52e91386df7bc69d3a973a38f19e3721f379528b17913b5a32bfab6101 fix-ppc64le-build-snprinf-buflen.patch"