aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmateweather
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:40 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:47 +0100
commite217298a190403f629f1f07454197d6bcc38155b (patch)
tree2df191383655b50702f64ac6a032c1ec25887b56 /community/libmateweather
parentcffc8523614e23f2d3cf4f42f999f41f3fde8136 (diff)
downloadaports-e217298a190403f629f1f07454197d6bcc38155b.tar.bz2
aports-e217298a190403f629f1f07454197d6bcc38155b.tar.xz
main/libmateweather: move to community
Diffstat (limited to 'community/libmateweather')
-rw-r--r--community/libmateweather/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/libmateweather/APKBUILD b/community/libmateweather/APKBUILD
new file mode 100644
index 0000000000..2de6b71efd
--- /dev/null
+++ b/community/libmateweather/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=libmateweather
+pkgver=1.10.0
+pkgrel=0
+pkgdesc="A library to access weather information from online services for numerous locations"
+url="https://github.com/mate-desktop/libmateweather"
+arch="all"
+license="GPL2"
+depends="mate-common"
+depends_dev=""
+makedepends="$depends_dev libsoup-dev libtool intltool gtk+2.0-dev
+ libxml2-utils"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-zoneinfo-dir \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="d6cdcc54059641f82b817e10c5656f06 libmateweather-1.10.0.tar.xz"
+sha256sums="4fc80145942781281efe99e17daef3d0947ae319771b2ab0a9b2a4559779484c libmateweather-1.10.0.tar.xz"
+sha512sums="80eed6693e13d4dccb4e44ebab84955f7cbbd4f536cda1186db694149bf013429f41f38d2cb03a0dae517d6438e5cff1c18ae95598f700a1a9184ac47f85fcf5 libmateweather-1.10.0.tar.xz"