aboutsummaryrefslogtreecommitdiffstats
path: root/community/libnumbertext
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-09-28 14:23:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-28 16:55:07 +0000
commit52fda09607ab48f45774584826bb9339f00bcbd6 (patch)
tree7964d8f204dde94d32664471d7cf3e3a3bc193a9 /community/libnumbertext
parentd60cab2c2244dca4c78b5028edb86f96b6b3437e (diff)
downloadaports-52fda09607ab48f45774584826bb9339f00bcbd6.tar.bz2
aports-52fda09607ab48f45774584826bb9339f00bcbd6.tar.xz
community/libnumbertext: new aport
needed by libreoffice
Diffstat (limited to 'community/libnumbertext')
-rw-r--r--community/libnumbertext/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/libnumbertext/APKBUILD b/community/libnumbertext/APKBUILD
new file mode 100644
index 0000000000..f434c137da
--- /dev/null
+++ b/community/libnumbertext/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libnumbertext
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="Number to number name and money text conversion library"
+url="https://github.com/Numbertext/libnumbertext"
+arch="all"
+license="(LGPLv3+ or BSD) and (LGPLv3+ or BSD or CC-BY-SA)"
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev"
+source="https://github.com/Numbertext/libnumbertext/releases/download/1.0/libnumbertext-$pkgver.tar.xz"
+builddir="$srcdir/libnumbertext-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ autoreconf -v --install --force
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0ce9c68c8d928f7c8aa13f4760360ab3077ff0923a6b34256a1ca1047b7401a7d99ac5205b80b3e57c6e693c59ccc8328e04cfebeee07794c906a1ab750a3a7a libnumbertext-1.0.3.tar.xz"