aboutsummaryrefslogtreecommitdiffstats
path: root/community/libplist/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-11 14:49:22 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 15:18:54 +0000
commit14f65b6fd3049eaed3cfe7a11a1d280c6a5ab991 (patch)
tree4214bec2858aa5e5c10deb1d9bdb06ba5564bcd8 /community/libplist/APKBUILD
parentb4d01daa0a5f345aeb990551278b0efd89e94d8e (diff)
downloadaports-14f65b6fd3049eaed3cfe7a11a1d280c6a5ab991.tar.bz2
aports-14f65b6fd3049eaed3cfe7a11a1d280c6a5ab991.tar.xz
community/libplist: fix license&py2 bindings build
* Modernize APKBUILD * Run tests Closes GH-7597
Diffstat (limited to 'community/libplist/APKBUILD')
-rw-r--r--community/libplist/APKBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/community/libplist/APKBUILD b/community/libplist/APKBUILD
index 79d9588d2e..b334bad99d 100644
--- a/community/libplist/APKBUILD
+++ b/community/libplist/APKBUILD
@@ -1,35 +1,36 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libplist
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A library to handle Apple Property List format whereas it's binary or XML"
url="http://libimobiledevice.org/"
arch="all"
-license="GPL-2.0 LGPL-2.1"
-depends=""
-depends_dev="libxml2-dev glib-dev"
-makedepends="py2-setuptools swig python2-dev $depends_dev python2 cython2"
-subpackages="$pkgname-dev py-$pkgname:py $pkgname-util $pkgname++:cxx"
+license="GPL-2.0-or-later LGPL-2.1-or-later"
+makedepends="py2-setuptools swig python2-dev glib-dev cython"
+subpackages="$pkgname-static $pkgname-dev py-$pkgname:py $pkgname-util $pkgname++:cxx"
source="http://www.libimobiledevice.org/downloads/libplist-$pkgver.tar.bz2"
-_builddir="$srcdir"/build
-_src="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"
- mkdir -p "$_builddir"
- cd "$_builddir"
- ac_cv_path_CYTHON=cython2 $_src/configure \
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --mandir=/usr/share/man \
- || return 1
- make || return 1
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ # https://github.com/libimobiledevice/libplist/issues/118
+ case "$CARCH" in
+ armv7) return 0;;
+ esac
+
+ make check -j1 # https://github.com/libimobiledevice/libimobiledevice/issues/777
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
util() {