aboutsummaryrefslogtreecommitdiffstats
path: root/community/libplist
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-07 09:55:33 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2015-10-07 15:43:45 +0200
commit3903686b9c2c8b8551196e3dc4c81d0d4fefadf4 (patch)
tree1e242dfca35c86c4381f9f3c705df2a92aab820d /community/libplist
parent386d01f1568ff757b6a8b31cf58d4eee7391c2c1 (diff)
downloadaports-3903686b9c2c8b8551196e3dc4c81d0d4fefadf4.tar.bz2
aports-3903686b9c2c8b8551196e3dc4c81d0d4fefadf4.tar.xz
community/libplist: move from main
it seems only kodi needs it
Diffstat (limited to 'community/libplist')
-rw-r--r--community/libplist/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/libplist/APKBUILD b/community/libplist/APKBUILD
new file mode 100644
index 0000000000..7733b336ca
--- /dev/null
+++ b/community/libplist/APKBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libplist
+pkgver=1.12
+pkgrel=0
+pkgdesc="A library to handle Apple Property List format whereas it's binary or XML"
+url="http://libimobiledevice.org/"
+arch="all"
+license="GPL2 LGPL2.1"
+depends=""
+depends_dev="libxml2-dev glib-dev"
+makedepends="swig python-dev $depends_dev cython-dev"
+subpackages="$pkgname-dev py-$pkgname:py $pkgname-util $pkgname++:cxx"
+source="http://www.libimobiledevice.org/downloads/libplist-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/build
+_src="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$srcdir"
+ mkdir -p "$_builddir"
+ cd "$_builddir"
+ $_src/configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+util() {
+ pkgdesc="Util for libplist"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+py() {
+ pkgdesc="Python bindings for libplist"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+cxx() {
+ pkgdesc="C++ bindings to libplist"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*++.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="8b04b0f09f2398022dcd4fba75012997 libplist-1.12.tar.bz2"
+sha256sums="0effdedcb3de128c4930d8c03a3854c74c426c16728b8ab5f0a5b6bdc0b644be libplist-1.12.tar.bz2"
+sha512sums="8af40d8f457ca9a8a9061e9429698c696200714cc05dcbe981e900106c52cd5222edb9dd8d8976bccd0c8997508ed14fb2e10f0ed29383f2ad4f7c5eb7eec0b3 libplist-1.12.tar.bz2"