aboutsummaryrefslogtreecommitdiffstats
path: root/community/libportal/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-07 09:02:54 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-07 07:36:38 -0300
commit2d51946283f96e789b8922d9baa755272e6f4709 (patch)
treeb9c00249a9246d38cc1c9a876ca385f68cb5adb3 /community/libportal/APKBUILD
parent85a9817554a1ead702abbf8697ae9cd7ab7b077a (diff)
downloadaports-2d51946283f96e789b8922d9baa755272e6f4709.tar.bz2
aports-2d51946283f96e789b8922d9baa755272e6f4709.tar.xz
community/libportal: move from community
Diffstat (limited to 'community/libportal/APKBUILD')
-rw-r--r--community/libportal/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/libportal/APKBUILD b/community/libportal/APKBUILD
new file mode 100644
index 0000000000..8bbc301f50
--- /dev/null
+++ b/community/libportal/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=libportal
+pkgver=0.3
+pkgrel=0
+pkgdesc="GIO-style async APIs for most Flatpak portals"
+url="https://github.com/flatpak/libportal"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="meson glib-dev gtk-doc"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/flatpak/libportal/archive/$pkgver.tar.gz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --buildtype=plain \
+ . output
+ ninja -C output
+}
+
+check() {
+ meson test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+sha512sums="eb62d786a9988a39b39d6238bbd420642e7bfc6b879952b6dac8aa407b81ec05ff01f0afda039e385ffa4794905d28edfb37bb77340f67625e252622c7ab2472 libportal-0.3.tar.gz"