aboutsummaryrefslogtreecommitdiffstats
path: root/community/libquvi-scripts
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-31 17:56:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:13 +0000
commitd452391d6af2cb8b8bca086cd1474bf896536a39 (patch)
treeb9bb32f56e397eb5d6df22d6400fd4750eb44965 /community/libquvi-scripts
parent8495e2fadb8864235a22bf5e257e455866421c2b (diff)
downloadaports-d452391d6af2cb8b8bca086cd1474bf896536a39.tar.bz2
aports-d452391d6af2cb8b8bca086cd1474bf896536a39.tar.xz
main/*quvi*: move to community
Diffstat (limited to 'community/libquvi-scripts')
-rw-r--r--community/libquvi-scripts/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/libquvi-scripts/APKBUILD b/community/libquvi-scripts/APKBUILD
new file mode 100644
index 0000000000..935fe9f80f
--- /dev/null
+++ b/community/libquvi-scripts/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libquvi-scripts
+pkgver=0.9.20131130
+pkgrel=0
+pkgdesc="scripts for libquvi - the library for parsing video download links"
+url="http://quvi.sourceforge.net/"
+arch="noarch"
+license="LGPL-2.0-or-later"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/project/quvi/${pkgver%.*}/$pkgname/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+ update_config_guess
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="46ddfd887260a515199c2e1ba8c46d8a libquvi-scripts-0.9.20131130.tar.xz"
+sha256sums="17f21f9fac10cf60af2741f2c86a8ffd8007aa334d1eb78ff6ece130cb3777e3 libquvi-scripts-0.9.20131130.tar.xz"
+sha512sums="97de4cead30dc181da700cbf3a0ad66ee709fef17f449f75cd43e0376a4aa53c7b2174188130aaa34dcc7ddc578581111f3655cb10f4b0c92df2f75d32c72a02 libquvi-scripts-0.9.20131130.tar.xz"