aboutsummaryrefslogtreecommitdiffstats
path: root/community/libre2
diff options
context:
space:
mode:
authordai9ah <dai9ah@protonmail.com>2018-03-03 12:40:41 +0000
committerJakub Jirutka <jakub@jirutka.cz>2018-03-04 17:01:01 +0100
commit037b7eed5f707b8054e0da1d24ed4be87fbbdbd6 (patch)
tree988841e740c41d12a9398c996e6e0c24590ad6d5 /community/libre2
parent5911cfc975f74a86e3111801109b1c14bbda7899 (diff)
downloadaports-037b7eed5f707b8054e0da1d24ed4be87fbbdbd6.tar.bz2
aports-037b7eed5f707b8054e0da1d24ed4be87fbbdbd6.tar.xz
community/libre2: add check
Diffstat (limited to 'community/libre2')
-rw-r--r--community/libre2/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/libre2/APKBUILD b/community/libre2/APKBUILD
index e5cf825f27..170639090d 100644
--- a/community/libre2/APKBUILD
+++ b/community/libre2/APKBUILD
@@ -9,7 +9,6 @@ pkgdesc="Efficient, principled regular expression library"
url="https://github.com/google/re2"
arch="all"
license="BSD-3-Clause"
-options="!check"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/google/$_pkgname/archive/$_pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$_pkgver
@@ -19,6 +18,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" prefix=/usr install