aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsass
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-10-13 01:06:07 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-10-13 01:07:01 +0200
commit601ca223dabf81f2bad3a1e4300b63b9d57ea1c0 (patch)
treee5fc8b47dcccd7d9b8b3f6362e006bd49223fbf6 /community/libsass
parent2eeea190d1b3949bc4f68c22a476a127caaca305 (diff)
downloadaports-601ca223dabf81f2bad3a1e4300b63b9d57ea1c0.tar.bz2
aports-601ca223dabf81f2bad3a1e4300b63b9d57ea1c0.tar.xz
community/libsass: move from testing
Diffstat (limited to 'community/libsass')
-rw-r--r--community/libsass/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/libsass/APKBUILD b/community/libsass/APKBUILD
new file mode 100644
index 0000000000..6ad4b0b4e5
--- /dev/null
+++ b/community/libsass/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+pkgname=libsass
+pkgver=3.3.6
+pkgrel=0
+pkgdesc="A C/C++ implementation of a Sass compiler"
+url="http://libsass.org"
+arch="all"
+license="MIT"
+depends=""
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sass/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ autoreconf -vif
+}
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+
+ make install DESTDIR="$pkgdir" || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="6bb2a93efb9802758ff7640ab69ce498 libsass-3.3.6.tar.gz"
+sha256sums="4b004b0fcef55420dc916216b1961e0d86925e6bf4a6be37d0b6db42f7f25da5 libsass-3.3.6.tar.gz"
+sha512sums="9bc81a2c75f301e95ee172b6a11dd022ba810bf00175387abe85ed395ce0cfd88f1998b0916a8a7e7920f3e4169da4a4c4a0f69bbb89ddce4af9b299a3091e57 libsass-3.3.6.tar.gz"