aboutsummaryrefslogtreecommitdiffstats
path: root/community/libselinux/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-16 20:56:39 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-16 20:56:39 +0000
commitffb345fd5e1f91b0e82aa379b98acd3e23afd4f9 (patch)
tree616625c6559f7bb659edadc7d6b690bae0ee9ca4 /community/libselinux/APKBUILD
parent2ee5e8ffbbdd4c5860017bb77d02c92bf347992d (diff)
downloadaports-ffb345fd5e1f91b0e82aa379b98acd3e23afd4f9.tar.bz2
aports-ffb345fd5e1f91b0e82aa379b98acd3e23afd4f9.tar.xz
testing/libselinux: move to community
Diffstat (limited to 'community/libselinux/APKBUILD')
-rw-r--r--community/libselinux/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/libselinux/APKBUILD b/community/libselinux/APKBUILD
new file mode 100644
index 0000000000..6e70975b29
--- /dev/null
+++ b/community/libselinux/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libselinux
+pkgver=2.6
+pkgrel=1
+pkgdesc="SELinux library and simple utilities"
+url="https://github.com/SELinuxProject/selinux/wiki"
+arch="all"
+license="Public-Domain"
+depends=""
+depends_dev=""
+# we need coreutils for ln --relative
+makedepends="$depends_dev pcre-dev linux-headers libsepol-dev fts-dev coreutils"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
+source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/libselinux-$pkgver.tar.gz
+ "
+
+builddir="$srcdir/libselinux-$pkgver"
+
+build() {
+ cd "$builddir"
+ make PCRE_LDFLAGS="-lpcre -lfts" || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+utils() {
+ pkgdesc="SELinux libselinux utilies"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/
+}
+
+sha512sums="906e1bf98c669862ab4f4e883d511db8d739a5763dc857c9405ad3cc6c70766a482853d07134698a1a98257a8632cc756d0549a7640c2915d051714f502ff14b libselinux-2.6.tar.gz"