aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsepol
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-16 22:06:59 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-16 22:06:59 +0000
commitbe89da4e6cf7c0b928b0eb299c45a6854d274651 (patch)
tree64c95adb4cee2edfbd5418e3a6dbb5b503bf2f79 /community/libsepol
parentc4248a0062f5561ff959dd738d4331f8d7d36101 (diff)
downloadaports-be89da4e6cf7c0b928b0eb299c45a6854d274651.tar.bz2
aports-be89da4e6cf7c0b928b0eb299c45a6854d274651.tar.xz
community/libsepol: upgrade to 2.8
Diffstat (limited to 'community/libsepol')
-rw-r--r--community/libsepol/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/libsepol/APKBUILD b/community/libsepol/APKBUILD
index d8310350ac..d0d471a2a2 100644
--- a/community/libsepol/APKBUILD
+++ b/community/libsepol/APKBUILD
@@ -1,28 +1,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libsepol
-pkgver=2.6
-pkgrel=1
+pkgver=2.8
+pkgrel=0
pkgdesc="SELinux binary policy manipulation library"
url="https://github.com/SELinuxProject/selinux/wiki"
arch="all"
license="LGPL-2.0-or-later"
-depends=""
depends_dev="bsd-compat-headers"
makedepends="$depends_dev flex-dev coreutils"
-install=""
+options="!check" # tests fail
subpackages="$pkgname-dev $pkgname-doc"
-source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/libsepol-$pkgver.tar.gz
+source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/libsepol-$pkgver.tar.gz
"
builddir="$srcdir/libsepol-$pkgver"
build() {
cd "$builddir"
- make || return 1
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="17d007857634e3d581fcc9bafcbb75674a06e382bb258c2c6b3656c141d71493699c42b78c8e1917c628476aeb8ead73bb86e8ccf43d7ce59aa0b7884bea132a libsepol-2.6.tar.gz"
+check() {
+ cd "$builddir"
+ make test
+}
+
+sha512sums="dd065886819a265cd4f2751ac231a7baa5d7c7735844f3557d5c7e1feb06d4b4d03433d26ff6419b426caf90b69771ee743850fe45d36bc0201cadb86c62189c libsepol-2.8.tar.gz"