aboutsummaryrefslogtreecommitdiffstats
path: root/community/libunique3
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /community/libunique3
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'community/libunique3')
-rw-r--r--community/libunique3/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/libunique3/APKBUILD b/community/libunique3/APKBUILD
new file mode 100644
index 0000000000..161ec3f6df
--- /dev/null
+++ b/community/libunique3/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libunique3
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="Library for writing single instance applications"
+url="http://live.gnome.org/LibUnique"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="gtk+3.0-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/libunique/${pkgver%.*}/libunique-$pkgver.tar.xz"
+
+builddir="$srcdir"/libunique-$pkgver
+
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-dbus
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b053b9f265c751bd581d15bf73246fb087075eaf75760565671c09a4ab80db342b4d2185050a877c4e25276d24f7895f4325ca60b918a7c4acd9d1591e97a8b4 libunique-3.0.2.tar.xz"