aboutsummaryrefslogtreecommitdiffstats
path: root/community/libwmf/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-08 04:42:33 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-08 16:11:51 +0000
commit8d3718890e2c104b6c2ea42f1c52e10773b2d17a (patch)
treeb428a5a457c6b4123e1ca96ea1881060d43aaca9 /community/libwmf/APKBUILD
parent8969bc28c0e2c56c30bf5d5f47f9d31d7e6c8689 (diff)
downloadaports-8d3718890e2c104b6c2ea42f1c52e10773b2d17a.tar.bz2
aports-8d3718890e2c104b6c2ea42f1c52e10773b2d17a.tar.xz
community/libwmf: upgrade to 0.2.12
Closes GH-8633
Diffstat (limited to 'community/libwmf/APKBUILD')
-rw-r--r--community/libwmf/APKBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/community/libwmf/APKBUILD b/community/libwmf/APKBUILD
index c557abc05d..d088390110 100644
--- a/community/libwmf/APKBUILD
+++ b/community/libwmf/APKBUILD
@@ -1,43 +1,37 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libwmf
-pkgver=0.2.8.4
-pkgrel=4
+pkgver=0.2.12
+pkgrel=0
pkgdesc="A library for reading vector images in Microsoft's native Windows Metafile Format (WMF)."
url="http://wvware.sourceforge.net/libwmf.html"
arch="all"
-license="LGPL"
+license="LGPL-2.0-or-later"
depends="ghostscript-fonts"
-makedepends="libpng-dev>=1.4.0 freetype-dev jpeg-dev>=8 expat-dev"
-install=
+makedepends="libpng-dev>=1.4.0 freetype-dev jpeg-dev>=8 expat-dev
+ automake autoconf libtool"
subpackages="$pkgname-dev"
-source="https://downloads.sourceforge.net/sourceforge/wvware/$pkgname-$pkgver.tar.gz
- libpng14.patch"
-
-builddir="$srcdir"/$pkgname-$pkgver
+source="$pkgname-$pkgver.tar.gz::https://github.com/caolanm/libwmf/archive/v$pkgver.tar.gz
+ freetype.patch
+ "
prepare() {
default_prepare
- update_config_guess
-
- cd "$builddir"
- sed -i -e 's/src include fonts doc/src include fonts/g' Makefile.in
+ autoreconf -fi -Ipatches
}
build() {
- cd "$builddir"
./configure --prefix=/usr \
--with-gsfontdir=/usr/share/fonts/Type1 \
--with-fontdir=/usr/share/fonts/Type1 \
- --with-gsfontmap=/usr/share/ghostscript/8.15/lib/Fontmap.GS
+ --with-gsfontmap=/usr/share/ghostscript/9.10/lib/Fontmap.GS
make
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
# Remove fonts, these are in ghostscript-fonts
rm -rf "$pkgdir/usr/share/fonts"
}
-sha512sums="d98df8e76a52245487b13e5ab3d2fbba9d246f97ee04a7344c0e5861bb2d0f990fc6d662dbd849ce621768b06eaebd4270fb34bec4ee004334a98b14ba6044a5 libwmf-0.2.8.4.tar.gz
-804a43fa37928a91a477cfc875e80b55ebfcb6682cc12e661ca70006df8c4326e2ecf8ce3ffefbee465597bf47abbbfe7762981205a366aac32a43e1e9e1da7b libpng14.patch"
+sha512sums="9280851e560becc91546906b911e0c59a1abd690e10680f6d94a335d66aeaec5eb12ccf2214ee7af2a15729a7b5f8b906022822399b4e2bc12c75a2d75748cab libwmf-0.2.12.tar.gz
+d60ec85731f4d797c7188883302dc816c77b7ad7d87fe5187e2237e84e0ccfb5b017a3398bb20f0fc14bad53270c8940360858063bb0ae063437d2a255e3874d freetype.patch"