aboutsummaryrefslogtreecommitdiffstats
path: root/community/libx86emu
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-03 00:50:02 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-03 00:50:02 +0200
commit6fe523efab6d0a5b6d27ad041b5a34ca05e20c2c (patch)
tree74fec774f142df1fdfc9053b3f56a754d1442f5e /community/libx86emu
parentde941aa0e60fd61769a165250bc8962ff86f6a4b (diff)
downloadaports-6fe523efab6d0a5b6d27ad041b5a34ca05e20c2c.tar.bz2
aports-6fe523efab6d0a5b6d27ad041b5a34ca05e20c2c.tar.xz
community/libx86emu: move from testing
Diffstat (limited to 'community/libx86emu')
-rw-r--r--community/libx86emu/APKBUILD34
-rw-r--r--community/libx86emu/ldflags.patch13
2 files changed, 47 insertions, 0 deletions
diff --git a/community/libx86emu/APKBUILD b/community/libx86emu/APKBUILD
new file mode 100644
index 0000000000..c6f6d33869
--- /dev/null
+++ b/community/libx86emu/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=libx86emu
+pkgver=1.12
+pkgrel=0
+pkgdesc="x86 emulation library"
+url="https://github.com/wfeldt/libx86emu"
+arch="all"
+license="BSD"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/wfeldt/$pkgname/archive/$pkgver.tar.gz
+ ldflags.patch"
+builddir="$srcdir/libx86emu-$pkgver"
+options="!check" # FIXME: test fails to build
+
+_flags="VERSION=$pkgver MAJOR_VERSION=${pkgver%%.*} GIT2LOG= LIBDIR=/usr/lib"
+
+build() {
+ cd "$builddir"
+ make shared $_flags CFLAGS="$CFLAGS -fPIC -Wall"
+}
+
+check() {
+ cd "$builddir"
+ make test $_flags CFLAGS="$CFLAGS -I../include"
+}
+
+package() {
+ cd "$builddir"
+ make $_flags DESTDIR="$pkgdir" install
+}
+
+sha512sums="7798ab62a42d52591bedb272e9ed5c23abba896318f2da79f8a42846715998505ceb28b7c865d25d76f3ee16d2a3bf97b2f81a4e1b7248f8dd864794113725c0 libx86emu-1.12.tar.gz
+87edc4f5bc3810a3faabe121f77f31ca503f867236a0dd3b924dd4fe7ebd1da5d49f01b90b192102161dd209c765a30ec3fb10ff658470bdd113707f702267bc ldflags.patch"
diff --git a/community/libx86emu/ldflags.patch b/community/libx86emu/ldflags.patch
new file mode 100644
index 0000000000..de9ca775d9
--- /dev/null
+++ b/community/libx86emu/ldflags.patch
@@ -0,0 +1,13 @@
+Patch-Source: https://src.fedoraproject.org/rpms/libx86emu/blob/f27/f/libx86emu-1.11-ldflags.patch
+
+--- a/Makefile
++++ b/Makefile
+@@ -45,7 +45,7 @@
+ install -m 644 -D include/x86emu.h $(DESTDIR)/usr/include/x86emu.h
+
+ $(LIB_NAME): .depend $(OBJS)
+- $(CC) -shared -Wl,-soname,$(LIB_SONAME) $(OBJS) -o $(LIB_NAME)
++ $(CC) -shared -Wl,-soname,$(LIB_SONAME) $(LDFLAGS) $(OBJS) -o $(LIB_NAME)
+
+ test:
+ make -C test