aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxdg-basedir
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-26 22:23:37 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-26 23:33:40 -0300
commit4d3992fa5ef5c94be7d36147012c4e5394cfb1f6 (patch)
treee2c7825bede2fcf9f09a0cc12effd9bbfa7e5cc7 /community/libxdg-basedir
parentf825a62e9c1f1badf1e09fbf589ecf65cf7f64b1 (diff)
downloadaports-4d3992fa5ef5c94be7d36147012c4e5394cfb1f6.tar.bz2
aports-4d3992fa5ef5c94be7d36147012c4e5394cfb1f6.tar.xz
community/libxdg-basedir: move from main
Diffstat (limited to 'community/libxdg-basedir')
-rw-r--r--community/libxdg-basedir/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/libxdg-basedir/APKBUILD b/community/libxdg-basedir/APKBUILD
new file mode 100644
index 0000000000..18ed00eac2
--- /dev/null
+++ b/community/libxdg-basedir/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxdg-basedir
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="library for XDG base dir specification"
+url="https://git.universe-factory.net/libuecc"
+arch="all"
+license="MIT"
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/devnev/libxdg-basedir/archive/libxdg-basedir-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+
+prepare() {
+ autoreconf -fi
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="8584405d45e0b57e570666b6eab6d99d70411d00f88965826c9ed0292372385668f190157a10ff536f3a5a59fd0031b332ecbb8a38ac64eda1b04a0603997406 libxdg-basedir-1.2.0.tar.gz"