aboutsummaryrefslogtreecommitdiffstats
path: root/community/lightdm-gtk-greeter
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2019-03-24 13:42:01 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-25 15:15:14 +0200
commitf73cb5c48ec938020c59024cc75f7b7d19ec9b31 (patch)
treee25c4cddff01e939600844c749cd5764574999ee /community/lightdm-gtk-greeter
parent107990a8c66b184eb8c116f2697fc76627e8b722 (diff)
downloadaports-f73cb5c48ec938020c59024cc75f7b7d19ec9b31.tar.bz2
aports-f73cb5c48ec938020c59024cc75f7b7d19ec9b31.tar.xz
testing/lightdm* -> community/
lightdm* : move from testing lightdm-gtk-greeter: upgrade to 2.0.6
Diffstat (limited to 'community/lightdm-gtk-greeter')
-rw-r--r--community/lightdm-gtk-greeter/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/lightdm-gtk-greeter/APKBUILD b/community/lightdm-gtk-greeter/APKBUILD
new file mode 100644
index 0000000000..2c8a0b79ea
--- /dev/null
+++ b/community/lightdm-gtk-greeter/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Taner Tas <taner76@gmail.com>
+# Maintainer: Taner Tas <taner76@gmail.com>
+pkgname=lightdm-gtk-greeter
+pkgver=2.0.6
+pkgrel=0
+pkgdesc="Gtk based greeter for lightdm."
+url="https://launchpad.net/lightdm-gtk-greeter"
+arch="all"
+license="GPL-3.0-or-later"
+depends="lightdm"
+makedepends="gtk+3.0-dev lightdm-dev exo-dev"
+subpackages="$pkgname-lang $pkgname-doc"
+source="https://launchpad.net/${pkgname}/${pkgver%.?}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz"
+options="!check"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --with-libxklavier \
+ --enable-kill-on-sigterm \
+ --disable-libido \
+ --disable-libindicator \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="778215351a9140f164c67c75d69efc55b1edf97a493f42a14e2a40e322f738cba99534274d00198291454466fbf407efdc927479c4821d04e12d742feb31cc3a lightdm-gtk-greeter-2.0.6.tar.gz"