aboutsummaryrefslogtreecommitdiffstats
path: root/community/lightdm
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2019-03-24 13:42:01 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-25 15:15:14 +0200
commitf73cb5c48ec938020c59024cc75f7b7d19ec9b31 (patch)
treee25c4cddff01e939600844c749cd5764574999ee /community/lightdm
parent107990a8c66b184eb8c116f2697fc76627e8b722 (diff)
downloadaports-f73cb5c48ec938020c59024cc75f7b7d19ec9b31.tar.bz2
aports-f73cb5c48ec938020c59024cc75f7b7d19ec9b31.tar.xz
testing/lightdm* -> community/
lightdm* : move from testing lightdm-gtk-greeter: upgrade to 2.0.6
Diffstat (limited to 'community/lightdm')
-rw-r--r--community/lightdm/APKBUILD72
-rw-r--r--community/lightdm/allow-null-passwd.patch11
-rw-r--r--community/lightdm/disallow-guest.patch22
-rwxr-xr-xcommunity/lightdm/lightdm.initd15
-rw-r--r--community/lightdm/lightdm.pre-install8
-rw-r--r--community/lightdm/musl-is-linux.patch11
-rw-r--r--community/lightdm/musl-language.patch36
-rw-r--r--community/lightdm/musl-updwtmpx.patch13
8 files changed, 188 insertions, 0 deletions
diff --git a/community/lightdm/APKBUILD b/community/lightdm/APKBUILD
new file mode 100644
index 0000000000..29ae57df0f
--- /dev/null
+++ b/community/lightdm/APKBUILD
@@ -0,0 +1,72 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lightdm
+pkgver=1.28.0
+pkgrel=2
+pkgdesc="A cross-desktop display manager"
+url="https://www.freedesktop.org/wiki/Software/LightDM"
+arch="all"
+license="GPL-3.0-or-later"
+depends="dbus xinit accountsservice gnome-themes-standard lightdm-gtk-greeter
+ adwaita-icon-theme"
+makedepends="linux-pam-dev gtk+3.0-dev libxext-dev libxklavier-dev
+ autoconf automake libtool gobject-introspection-dev itstool
+ libgcrypt-dev libxml2-utils intltool qt5-qtbase-dev"
+install="$pkgname.pre-install"
+pkgusers="lightdm"
+pkggroups="lightdm"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-openrc $pkgname-qt5 $pkgname-qt5-dev:qt5_dev"
+source="https://github.com/CanonicalLtd/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz
+ musl-language.patch
+ musl-is-linux.patch
+ musl-updwtmpx.patch
+ disallow-guest.patch
+ allow-null-passwd.patch
+ lightdm.initd"
+
+build() {
+ cd "$builddir"
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-liblightdm-gobject \
+ --disable-tests \
+ --with-greeter-session=lightdm-gtk-greeter
+
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ sed -i "s/pam_systemd/pam_elogind/" "$pkgdir"/etc/pam.d/*
+ ln -s /etc/X11/xinit/Xsession "$pkgdir"/usr/bin/lightdm-session
+ install -Dm755 "$srcdir"/lightdm.initd "$pkgdir"/etc/init.d/lightdm
+ install -o lightdm -g lightdm -d "$pkgdir"/var/lib/lightdm-data
+ rm -rf "$pkgdir"/etc/apparmor.d
+}
+
+qt5() {
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/liblightdm-qt5* "$subpkgdir"/usr/lib
+}
+
+qt5_dev() {
+ mkdir -p "$subpkgdir"/usr/lib/pkgconfig "$subpkgdir"/usr/include
+ mv "$pkgdir"/../$pkgname-dev/usr/include/lightdm-qt5-3 "$subpkgdir"/usr/include/
+ mv "$pkgdir"/../$pkgname-dev/usr/lib/liblightdm-qt5-3.* "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/../$pkgname-dev/usr/lib/pkgconfig/liblightdm-qt5-3.pc "$subpkgdir"/usr/lib/pkgconfig/
+}
+
+sha512sums="e1e8a952e723bbcc106043d33a64278b228a5a47a7e54235375817b08483594cc5e46ec52f5cbb9d258266e44b045785bca1d4c62daf83071c0f668b3c480071 lightdm-1.28.0.tar.xz
+592d630bdabeed304f8b677ceb0ebd2a6ab0930baae473814aafb0d58b7e28a79c8c667f18a656a460132c48a9fee90be7eebd50f835ea641d6d99387b28310a musl-language.patch
+aa33888f61b61f6c8082c77dc0b539fa14fb395c17e70b825ba88af7bb6adaad8f99583342a77442c60c105c1b83dd6eb0547fbddb43dcd767d9ad2c65ca2baf musl-is-linux.patch
+876088f21e502630c7d13343b03785d3327727c25657690c8e1cff5428a36944eb75d538f24ab4f5b11f931d8fad51241f25046da370eb5868aa8d2860be4eb2 musl-updwtmpx.patch
+c5bf8cfc0b4c4f95d9c9a3fa517b6c8ec90e02d84fb4498176b4745ed6089576fab536e9a3595200443811f05f2d47ac5e7c0205c878d9c23eff4dda7093ad6c disallow-guest.patch
+7d31a5d7034e665a86a7067654c8865fa5db98b58c32afab6077d589c0cd1351bfbfb4625e5e1b2ccf8c98bc08e7c97412c528311c3c32da0b8e45916f8de767 allow-null-passwd.patch
+212fb5830e6c76a3e396d38d55ad03b5a4a49f4ddc48fe60976612cee1ab5f0cc9867129e676929b421557be84c4db6699850a0408de9b16bd5ef34b6c7fbd51 lightdm.initd"
diff --git a/community/lightdm/allow-null-passwd.patch b/community/lightdm/allow-null-passwd.patch
new file mode 100644
index 0000000000..0d30d5d7f9
--- /dev/null
+++ b/community/lightdm/allow-null-passwd.patch
@@ -0,0 +1,11 @@
+--- a/data/pam/lightdm 2018-04-29 21:13:23.633200880 +0300
++++ b/data/pam/lightdm 2018-04-29 21:14:24.817767352 +0300
+@@ -7,7 +7,7 @@
+ auth required pam_env.so
+
+ # Use /etc/passwd and /etc/shadow for passwords
+-auth required pam_unix.so
++auth required pam_unix.so nullok
+
+ # Check account is active, change password if required
+ account required pam_unix.so
diff --git a/community/lightdm/disallow-guest.patch b/community/lightdm/disallow-guest.patch
new file mode 100644
index 0000000000..237b571094
--- /dev/null
+++ b/community/lightdm/disallow-guest.patch
@@ -0,0 +1,22 @@
+--- a/src/lightdm.c
++++ b/src/lightdm.c
+@@ -779,7 +779,7 @@
+ if (!config_has_key (config_get_instance (), "Seat:*", "allow-user-switching"))
+ config_set_boolean (config_get_instance (), "Seat:*", "allow-user-switching", TRUE);
+ if (!config_has_key (config_get_instance (), "Seat:*", "allow-guest"))
+- config_set_boolean (config_get_instance (), "Seat:*", "allow-guest", TRUE);
++ config_set_boolean (config_get_instance (), "Seat:*", "allow-guest", FALSE);
+ if (!config_has_key (config_get_instance (), "Seat:*", "greeter-allow-guest"))
+ config_set_boolean (config_get_instance (), "Seat:*", "greeter-allow-guest", TRUE);
+ if (!config_has_key (config_get_instance (), "Seat:*", "greeter-show-remote-login"))
+--- a/data/lightdm.conf
++++ b/data/lightdm.conf
+@@ -112,7 +112,7 @@
+ #greeter-show-remote-login=true
+ #user-session=default
+ #allow-user-switching=true
+-#allow-guest=true
++#allow-guest=false
+ #guest-session=
+ #session-wrapper=lightdm-session
+ #greeter-wrapper=
diff --git a/community/lightdm/lightdm.initd b/community/lightdm/lightdm.initd
new file mode 100755
index 0000000000..6de51487e5
--- /dev/null
+++ b/community/lightdm/lightdm.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+
+depend() {
+ need localmount dbus
+}
+
+description="Lightweight Display Manager"
+command="/usr/bin/lightdm"
+command_background="yes"
+pidfile="/run/lightdm.pid"
+
+start_pre() {
+ checkpath --owner lightdm:lightdm --directory /run/lightdm
+}
+
diff --git a/community/lightdm/lightdm.pre-install b/community/lightdm/lightdm.pre-install
new file mode 100644
index 0000000000..ab2add4883
--- /dev/null
+++ b/community/lightdm/lightdm.pre-install
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+name=lightdm
+
+addgroup -S $name 2>/dev/null
+adduser -S -D -H -h /var/run/lightdm -s /bin/false -G $name -g $name $name 2>/dev/null
+
+exit 0
diff --git a/community/lightdm/musl-is-linux.patch b/community/lightdm/musl-is-linux.patch
new file mode 100644
index 0000000000..697eff2470
--- /dev/null
+++ b/community/lightdm/musl-is-linux.patch
@@ -0,0 +1,11 @@
+--- a/tests/src/libsystem.c
++++ b/tests/src/libsystem.c
+@@ -213,7 +213,7 @@
+ return g_strdup (path);
+ }
+
+-#ifdef __linux__
++#ifdef __GLIBC__
+ static int
+ open_wrapper (const char *func, const char *pathname, int flags, mode_t mode)
+ {
diff --git a/community/lightdm/musl-language.patch b/community/lightdm/musl-language.patch
new file mode 100644
index 0000000000..442e7fb9d5
--- /dev/null
+++ b/community/lightdm/musl-language.patch
@@ -0,0 +1,36 @@
+--- a/liblightdm-gobject/language.c
++++ b/liblightdm-gobject/language.c
+@@ -210,6 +210,7 @@
+
+ if (!priv->name)
+ {
++ #if HAVE_LC_IDENTIFICATION
+ g_autofree gchar *locale = get_locale_name (priv->code);
+ if (locale)
+ {
+@@ -223,6 +224,8 @@
+
+ setlocale (LC_ALL, current);
+ }
++ #endif
++
+ if (!priv->name)
+ {
+ g_auto(GStrv) tokens = g_strsplit_set (priv->code, "_.@", 2);
+@@ -250,6 +253,7 @@
+
+ if (!priv->territory && strchr (priv->code, '_'))
+ {
++ #if HAVE_LC_IDENTITIFICATION
+ g_autofree gchar *locale = get_locale_name (priv->code);
+ if (locale)
+ {
+@@ -263,6 +267,8 @@
+
+ setlocale (LC_ALL, current);
+ }
++ #endif
++
+ if (!priv->territory)
+ {
+ g_auto(GStrv) tokens = g_strsplit_set (priv->code, "_.@", 3);
diff --git a/community/lightdm/musl-updwtmpx.patch b/community/lightdm/musl-updwtmpx.patch
new file mode 100644
index 0000000000..1b21a46774
--- /dev/null
+++ b/community/lightdm/musl-updwtmpx.patch
@@ -0,0 +1,13 @@
+--- a/src/session-child.c
++++ b/src/session-child.c
+@@ -193,8 +193,8 @@
+ }
+
+ /* GNU provides this but we can't rely on that so let's make our own version */
+-static void
+-updwtmpx (const gchar *wtmp_file, struct utmpx *ut)
++void
++updwtmpx (const char *wtmp_file, const struct utmpx *ut)
+ {
+ struct utmp u;
+ memset (&u, 0, sizeof (u));