aboutsummaryrefslogtreecommitdiffstats
path: root/community/lightdm
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 17:49:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 20:36:17 -0300
commitfab149c157a21cec320121d55c7bb478396033d6 (patch)
treefca48d6f6c5bdbae092a7445d481d272e1b97ae7 /community/lightdm
parent482cbe2a24cea728769c5f23ef469d5e885f2bdc (diff)
downloadaports-fab149c157a21cec320121d55c7bb478396033d6.tar.bz2
aports-fab149c157a21cec320121d55c7bb478396033d6.tar.xz
community/lightdm: enable vala support
Diffstat (limited to 'community/lightdm')
-rw-r--r--community/lightdm/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/community/lightdm/APKBUILD b/community/lightdm/APKBUILD
index 9850bbf851..e3e9718d61 100644
--- a/community/lightdm/APKBUILD
+++ b/community/lightdm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lightdm
pkgver=1.28.0
-pkgrel=3
+pkgrel=4
pkgdesc="A cross-desktop display manager"
url="https://www.freedesktop.org/wiki/Software/LightDM"
arch="all"
@@ -11,7 +11,7 @@ depends="dbus xinit accountsservice gnome-themes-standard
adwaita-icon-theme"
makedepends="linux-pam-dev gtk+3.0-dev libxext-dev libxklavier-dev
autoconf automake libtool gobject-introspection-dev itstool
- libgcrypt-dev libxml2-utils intltool qt5-qtbase-dev"
+ libgcrypt-dev libxml2-utils intltool qt5-qtbase-dev vala"
install="$pkgname.pre-install"
pkgusers="lightdm"
pkggroups="lightdm"
@@ -25,7 +25,6 @@ source="https://github.com/CanonicalLtd/${pkgname}/releases/download/${pkgver}/$
lightdm.initd"
build() {
- cd "$builddir"
export CFLAGS="$CFLAGS -D_GNU_SOURCE"
./configure \
--build=$CBUILD \
@@ -34,15 +33,14 @@ build() {
--sbindir=/usr/bin \
--sysconfdir=/etc \
--localstatedir=/var \
- --enable-liblightdm-gobject \
--disable-tests \
+ --enable-vala \
--with-greeter-session=lightdm-gtk-greeter
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
sed -i "s/pam_systemd/pam_elogind/" "$pkgdir"/etc/pam.d/*
ln -s /etc/X11/xinit/Xsession "$pkgdir"/usr/bin/lightdm-session