aboutsummaryrefslogtreecommitdiffstats
path: root/community/lld
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-12-26 14:33:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-26 14:36:06 +0000
commitbdd27feac65856faa07cdf6ecd86cb7de2312f4a (patch)
tree9d9ef7a3e06e8a180db542ccdcef1219a42ab3cb /community/lld
parentde347da9309d222ca4a6884da1d3e10b26387e83 (diff)
downloadaports-bdd27feac65856faa07cdf6ecd86cb7de2312f4a.tar.bz2
aports-bdd27feac65856faa07cdf6ecd86cb7de2312f4a.tar.xz
community/lld: set default thread stack size to 2MB
lld uses std::call_once to create threads and apparently it uses much stack space when linking things like chromium. Increase the default stack size to 2MB (which is the double what windows has) fixes #11086
Diffstat (limited to 'community/lld')
-rw-r--r--community/lld/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/lld/APKBUILD b/community/lld/APKBUILD
index 85c659c98d..7d59deed98 100644
--- a/community/lld/APKBUILD
+++ b/community/lld/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=lld
pkgver=9.0.1
-pkgrel=0
+pkgrel=1
_llvmver=${pkgver%%.*}
pkgdesc="The LLVM Linker"
url="https://llvm.org"
@@ -30,7 +30,7 @@ build() {
-DCMAKE_VERBOSE_MAKEFILE=OFF \
-DCMAKE_C_FLAGS_MINSIZEREL_INIT="$CFLAGS" \
-DCMAKE_CXX_FLAGS_MINSIZEREL_INIT="$CXXFLAGS -fpermissive" \
- -DCMAKE_EXE_LINKER_FLAGS_MINSIZEREL_INIT="$LDFLAGS" \
+ -DCMAKE_EXE_LINKER_FLAGS_MINSIZEREL_INIT="$LDFLAGS -Wl,-z,stack-size=2097152" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DLLVM_INCLUDE_TESTS=ON