aboutsummaryrefslogtreecommitdiffstats
path: root/community/lmdb
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-28 14:09:40 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-28 14:09:40 -0600
commit1741feb1311e51965bada4e850e5f9d4a484c479 (patch)
treef1e7a7ba2070690f801173dfae7d4157602e98b9 /community/lmdb
parentee494451873fbceba72cc4fba788d17c7de0f12e (diff)
downloadaports-1741feb1311e51965bada4e850e5f9d4a484c479.tar.bz2
aports-1741feb1311e51965bada4e850e5f9d4a484c479.tar.xz
community/lmdb: add test suite, fix license
Diffstat (limited to 'community/lmdb')
-rw-r--r--community/lmdb/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/lmdb/APKBUILD b/community/lmdb/APKBUILD
index ccf9ca2a27..76b7710329 100644
--- a/community/lmdb/APKBUILD
+++ b/community/lmdb/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer:
pkgname=lmdb
pkgver=0.9.21
-pkgrel=1
+pkgrel=2
pkgdesc="Lightning Memory-Mapped Database"
url="http://symas.com/mdb/"
arch="all"
-license="custom"
+license="OLDAP-2.8"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="https://github.com/LMDB/lmdb/archive/LMDB_$pkgver.tar.gz
lmdb_make.patch"
@@ -14,12 +14,17 @@ builddir="$srcdir/$pkgname-LMDB_$pkgver/libraries/liblmdb"
build() {
cd "$builddir"
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
tools() {