aboutsummaryrefslogtreecommitdiffstats
path: root/community/log4cplus
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-12-08 14:19:51 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-12-08 14:20:37 +0100
commit89442b46ccb0f877da416a75e0f073547b0278f4 (patch)
treed263b4795d29bd0ca8f215ed7ff9e6360e2246eb /community/log4cplus
parent959e6f356eb15f54958ed08ec260e6941658bfdd (diff)
downloadaports-89442b46ccb0f877da416a75e0f073547b0278f4.tar.bz2
aports-89442b46ccb0f877da416a75e0f073547b0278f4.tar.xz
common/log4cplus: move from testing and take maintainership
I need it for Kea package.
Diffstat (limited to 'community/log4cplus')
-rw-r--r--community/log4cplus/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/log4cplus/APKBUILD b/community/log4cplus/APKBUILD
new file mode 100644
index 0000000000..d6141c269c
--- /dev/null
+++ b/community/log4cplus/APKBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=log4cplus
+pkgver=2.0.4
+pkgrel=1
+pkgdesc="Logging Framework for C++"
+url="https://sourceforge.net/p/log4cplus/wiki/Home/"
+# tests/testsuite.dir/58/testsuite.log
+# 4 ./appender_test.at:5: "${abs_top_builddir}/appender_test" 2>&1
+# 5 Aborted (core dumped)
+arch="all !armhf !armv7" # test 50 dumps core
+license="Apache-2.0"
+checkdepends="findutils"
+subpackages="$pkgname-static $pkgname-dev $pkgname-unicode"
+source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-implicit-initialization \
+ --enable-lto \
+ --enable-static \
+ --with-working-c-locale
+ make
+}
+
+check() {
+ make check || {
+ find -name testsuite.log -type f -ls \
+ -printf '%P {{{\n' \
+ -exec cat -v -n '{}' ';' \
+ -printf '}}} %P\n'
+ return 1
+ }
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+unicode() {
+ pkgdesc="$pkgdesc (Unicode)"
+
+ amove ./usr/lib/liblog4cplusU*
+}
+
+sha512sums="4bb5a5475b8cae599d24f99f71beaadfdba19ce7d20ac0a4c43ed5b2634aebfd503b253bfc53df912b0bf5b6d8aad8f1f488436ea9bccecdd048ca0bcf2ce9d4 log4cplus-2.0.4.tar.xz"