aboutsummaryrefslogtreecommitdiffstats
path: root/community/loksh
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-04-20 11:05:57 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-04-20 12:01:21 +0200
commitc16b2092fc9e5492d062853ec74e459783c05d7f (patch)
tree9a16a32f325ba7730f419c67476acf3974270491 /community/loksh
parent85402c773234bc3c667fda98f70410092e26eac1 (diff)
downloadaports-c16b2092fc9e5492d062853ec74e459783c05d7f.tar.bz2
aports-c16b2092fc9e5492d062853ec74e459783c05d7f.tar.xz
community/loksh: upgrade to 6.1, modernize APKBUILD
Diffstat (limited to 'community/loksh')
-rw-r--r--community/loksh/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/community/loksh/APKBUILD b/community/loksh/APKBUILD
index 0c13dd65f1..eb29239083 100644
--- a/community/loksh/APKBUILD
+++ b/community/loksh/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=loksh
-pkgver=6.0
+pkgver=6.1
pkgrel=0
pkgdesc="A Linux port of OpenBSD's ksh"
url="https://github.com/dimkr/$pkgname"
@@ -12,21 +12,20 @@ depends=""
depends_dev=""
makedepends=""
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
+options="!check"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/dimkr/$pkgname/archive/$pkgver.tar.gz"
-
builddir="$srcdir"/$pkgname-$pkgver
+
build() {
- make -C "$builddir" || return 1
+ make -C "$builddir"
}
package() {
make DESTDIR="$pkgdir" \
PREFIX="/usr" \
BIN_DIR="/bin" \
- -C "$builddir" install || return 1
+ -C "$builddir" install
}
-md5sums="6a1ebc279d2f2e478c5ed72950ab7428 loksh-6.0.tar.gz"
-sha256sums="def14be261b14b93f04b575175d357682d68dd79e1569ada39339674480da070 loksh-6.0.tar.gz"
-sha512sums="a29ff288ae0980e8f9b239a5127df4a97c71c6b312537ef4a173355dc88cc24d68a714b5b4225fe2428e3e9759ca003ec84fa76c62a0771bf0b0e1d714a5566f loksh-6.0.tar.gz"
+sha512sums="5892e02b7f50727a22902372607e880123bb820fd2aac307f721a3fca0dc112281de8a527f8be3ae0f8c4f21cd92de83f4adba1425085f6344ed47d75a585c1b loksh-6.1.tar.gz"