aboutsummaryrefslogtreecommitdiffstats
path: root/community/loudmouth
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /community/loudmouth
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'community/loudmouth')
-rw-r--r--community/loudmouth/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/loudmouth/APKBUILD b/community/loudmouth/APKBUILD
new file mode 100644
index 0000000000..aa47277a89
--- /dev/null
+++ b/community/loudmouth/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=loudmouth
+pkgver=1.5.3
+pkgrel=1
+pkgdesc="A lightweight Jabber client library"
+url="http://groups.google.com/group/loudmouth-dev"
+arch="all"
+license="LGPL-2.0-or-later"
+depends_dev="pkgconfig gnutls-dev libidn-dev libasyncns-dev check-dev autoconf"
+makedepends="$depends_dev glib-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://mcabber.com/files/loudmouth/loudmouth-$pkgver.tar.bz2"
+
+prepare() {
+ default_prepare
+ autoconf
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --disable-static \
+ --with-asyncns=yes \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ab6b16b4e644b69cdb7d8df1753d1bb5b43c2f1e76944e639339169b332e1b5c6a4246053c5b8a579ee9b53c845cef610b0040dfdffeb857180b6bab71adfcce loudmouth-1.5.3.tar.bz2"