aboutsummaryrefslogtreecommitdiffstats
path: root/community/ltb-project-ssp
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-12-25 16:58:15 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-27 12:40:27 +0000
commita506031ab536154f83c0162f9c30cdee32282800 (patch)
treeb4ffd1eec1c8615a9171ef14cf365d730e8c1464 /community/ltb-project-ssp
parent6e9db44cd32467d9ea613fe6d4df21aa009f6388 (diff)
downloadaports-a506031ab536154f83c0162f9c30cdee32282800.tar.bz2
aports-a506031ab536154f83c0162f9c30cdee32282800.tar.xz
community/ltb-project-ssp: upgrade to 1.3 and modernize
Diffstat (limited to 'community/ltb-project-ssp')
-rw-r--r--community/ltb-project-ssp/APKBUILD15
-rw-r--r--community/ltb-project-ssp/ltb-project-ssp-move-config-location.patch4
-rw-r--r--community/ltb-project-ssp/ssp-0.8-add-crypt-algorithm-option.patch27
3 files changed, 6 insertions, 40 deletions
diff --git a/community/ltb-project-ssp/APKBUILD b/community/ltb-project-ssp/APKBUILD
index fb30f507f1..43c1bf09fa 100644
--- a/community/ltb-project-ssp/APKBUILD
+++ b/community/ltb-project-ssp/APKBUILD
@@ -1,27 +1,21 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname="ltb-project-ssp"
_realname="ltb-project-self-service-password"
-pkgver="1.0"
+pkgver="1.3"
pkgrel=0
pkgdesc="PHP application that allows users to change their password in an LDAP directory"
url="https://ltb-project.org/wiki/documentation/self-service-password"
arch="noarch"
license="GPL"
_php=php7
-depends="$_php ${_php}-ldap ${_php}-mcrypt"
+depends="$_php ${_php}-ldap ${_php}-openssl ${_php}-sodium"
makedepends="$depends_dev"
options="!check"
source="http://ltb-project.org/archives/ltb-project-self-service-password-$pkgver.tar.gz
ltb-project-ssp-move-config-location.patch
- ssp-0.8-add-crypt-algorithm-option.patch
"
builddir="$srcdir"/$_realname-$pkgver
-prepare() {
- cd "$builddir"
- default_prepare
-}
-
build() {
return 0
}
@@ -34,6 +28,5 @@ package() {
cp -r * "$pkgdir"/usr/share/webapps/ltb-project/ssp
}
-sha512sums="1d4591fa3c3a72bec2cf2584fae27f62ac22b7111144cd7df3f4c3d8485e174822117c68ab0c7e6d2fa49f6d6d0bba7c2aa367661b78e34bd9303cd9a33e8cd7 ltb-project-self-service-password-1.0.tar.gz
-70151388b681a6af43d0861f3741ecf2573f1c9f4f79258bb7f66e54cd80ca57f895f371f5e1369c424f5a2059a406c90f8ad3ce3245357e5d2b51edf578826c ltb-project-ssp-move-config-location.patch
-43f4e0e82a396c8caeeeb41d18d14886c051ccb18d061081f7c84f8bbe9b8a15d618e2a02480483659b04a82218408b71557acc6414731695f0f691c3cdce232 ssp-0.8-add-crypt-algorithm-option.patch"
+sha512sums="71aec5a3673ee710d4ba4a17862c695e0775ad944d85c8e05e826774010b8e905af5ab9e75886bc8c2efb9d9372ffe00d8856024e9656e1c71a57017b0eeac6d ltb-project-self-service-password-1.3.tar.gz
+52354e07d19d01066fbd95ad95cb1e42e6c2798258c34e6e90225cb60b035427fd639232e4686ba55bafd543215dded9d3428a7c0b31b548a73f3bb9d3b61ba2 ltb-project-ssp-move-config-location.patch"
diff --git a/community/ltb-project-ssp/ltb-project-ssp-move-config-location.patch b/community/ltb-project-ssp/ltb-project-ssp-move-config-location.patch
index a7f0df7128..57171d42cb 100644
--- a/community/ltb-project-ssp/ltb-project-ssp-move-config-location.patch
+++ b/community/ltb-project-ssp/ltb-project-ssp-move-config-location.patch
@@ -1,11 +1,11 @@
--- a/index.php
+++ b/index.php
-@@ -22,7 +22,7 @@
+@@ -24,7 +24,7 @@
#==============================================================================
# Includes
#==============================================================================
-require_once("conf/config.inc.php");
+require_once("/etc/ltb-project/ssp/conf/config.inc.php");
+ require_once("lib/vendor/defuse-crypto.phar");
require_once("lib/functions.inc.php");
if ($use_recaptcha) {
- require_once("lib/recaptchalib.php");
diff --git a/community/ltb-project-ssp/ssp-0.8-add-crypt-algorithm-option.patch b/community/ltb-project-ssp/ssp-0.8-add-crypt-algorithm-option.patch
deleted file mode 100644
index 8abb818f51..0000000000
--- a/community/ltb-project-ssp/ssp-0.8-add-crypt-algorithm-option.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/conf/config.inc.php b/conf/config.inc.php
-index 1aae0f6..f78da93 100644
---- a/conf/config.inc.php
-+++ b/conf/config.inc.php
-@@ -59,6 +59,9 @@ $shadow_options['update_shadowLastChange'] = false;
- # This option is not used with ad_mode = true
- $hash = "SSHA";
-
-+# prefix to use for salt with CRYPT
-+$crypt_salt_prefix = "$6$";
-+
- # Local password policy
- # This is applied before directory password policy
- # Minimal length
-diff --git a/lib/functions.inc.php b/lib/functions.inc.php
-index 03e7258..1870692 100644
---- a/lib/functions.inc.php
-+++ b/lib/functions.inc.php
-@@ -62,7 +62,7 @@ function make_crypt_password($password) {
- while( strlen( $salt ) < 2 )
- $salt .= substr( $possible, ( rand() % strlen( $possible ) ), 1 );
-
-- $hash = '{CRYPT}' . crypt( $password, $salt);
-+ $hash = '{CRYPT}' . crypt( $password, $GLOBALS['crypt_salt_prefix'].$salt);
- return $hash;
- }
-