aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-basexx
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 03:38:52 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 07:58:06 -0300
commit3c05debcc4899c33c66cf2884106f89f5d3321e6 (patch)
tree6c80f91fddee4e735ff450f45852add375f2da2a /community/lua-basexx
parent3bc1b75f27821f4a2cd6e56db1a47c2689602167 (diff)
downloadaports-3c05debcc4899c33c66cf2884106f89f5d3321e6.tar.bz2
aports-3c05debcc4899c33c66cf2884106f89f5d3321e6.tar.xz
community/lua-basexx: enable luajit on s390x
Diffstat (limited to 'community/lua-basexx')
-rw-r--r--community/lua-basexx/APKBUILD13
1 files changed, 2 insertions, 11 deletions
diff --git a/community/lua-basexx/APKBUILD b/community/lua-basexx/APKBUILD
index 867be0b371..dd09eb8033 100644
--- a/community/lua-basexx/APKBUILD
+++ b/community/lua-basexx/APKBUILD
@@ -8,17 +8,10 @@ pkgdesc="A Lua library for base2, base16, base32, base64, base85 decoding and en
url="https://github.com/aiq/basexx/"
arch="noarch"
license="MIT"
-checkdepends="lua-busted"
-subpackages=""
+checkdepends="lua-busted luajit"
source="$pkgname-$pkgver.tar.gz::https://github.com/aiq/$_pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-# luajit is not available for selected arches
-case "$CARCH" in
- s390x) _luajit="";;
- *) checkdepends="$checkdepends luajit" _luajit="jit";;
-esac
-
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
@@ -26,9 +19,7 @@ for _v in $_luaversions; do
done
check() {
- cd "$builddir"
-
- local lver; for lver in $_luaversions $_luajit; do
+ local lver; for lver in $_luaversions jit; do
msg "Testing on lua$lver"
lua$lver /usr/bin/busted
done