aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-copas
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-31 15:43:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-31 15:43:27 +0000
commita9031ebe509bf2b71f0fdf3b74cc8318e0eea5ad (patch)
treeeab34c73534cfc94ddc29fe7cd12d6e07836f6c1 /community/lua-copas
parentb807ec15de6f3fa4441be909692dc393b59a6ce1 (diff)
downloadaports-a9031ebe509bf2b71f0fdf3b74cc8318e0eea5ad.tar.bz2
aports-a9031ebe509bf2b71f0fdf3b74cc8318e0eea5ad.tar.xz
community/lua-copas: disable tests with https
apparently lua-sec does not work.
Diffstat (limited to 'community/lua-copas')
-rw-r--r--community/lua-copas/APKBUILD2
-rw-r--r--community/lua-copas/disable-https-tests.patch15
2 files changed, 17 insertions, 0 deletions
diff --git a/community/lua-copas/APKBUILD b/community/lua-copas/APKBUILD
index d8b8e853c4..bb32e3795a 100644
--- a/community/lua-copas/APKBUILD
+++ b/community/lua-copas/APKBUILD
@@ -13,6 +13,7 @@ depends="lua-socket"
checkdepends="lua5.1-coxpcall lua-sec"
subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/keplerproject/$_pkgname/archive/v$_pkgver.tar.gz
+ disable-https-tests.patch
ipv4-only.patch"
builddir="$srcdir/$_pkgname-$_pkgver"
@@ -58,4 +59,5 @@ _subpackage() {
}
sha512sums="dd83a513fbddb2f0164c3573b417623f5cc556413c4937be7e362f4c1667bad83391143e1bf609480726730ce488c4080e810f2ce12a98a7abb5293993c10182 lua-copas-2.0.2.tar.gz
+eebded0a9accbc6b0a5ecd3c45e06710bf4b3279605b443fe3bfff40d9d9d23bdc0c508fb42506d14faa69a3c4cee0b8bef80ab8b721eac6d5aeab2aaa8c41e7 disable-https-tests.patch
4fb2b65f41869b9729cc4672eebbfb2745a2d01af1cd54341b8306f57510f98e118eac77c77a980f4c8e8b181b6fda150061dc39819269e9ee64bf07656dfd54 ipv4-only.patch"
diff --git a/community/lua-copas/disable-https-tests.patch b/community/lua-copas/disable-https-tests.patch
new file mode 100644
index 0000000000..5858048032
--- /dev/null
+++ b/community/lua-copas/disable-https-tests.patch
@@ -0,0 +1,15 @@
+diff --git a/Makefile b/Makefile
+index 5b383d3..9d8c749 100644
+--- a/Makefile
++++ b/Makefile
+@@ -24,8 +24,8 @@ install:
+ test:
+ $(LUA) $(PKGPATH) tests/largetransfer.lua
+ $(LUA) $(PKGPATH) tests/request.lua 'http://www.google.com'
+- $(LUA) $(PKGPATH) tests/request.lua 'https://www.google.nl'
+- $(LUA) $(PKGPATH) tests/httpredirect.lua
++# $(LUA) $(PKGPATH) tests/request.lua 'https://www.google.nl'
++# $(LUA) $(PKGPATH) tests/httpredirect.lua
+ $(LUA) $(PKGPATH) tests/limit.lua
+ $(LUA) $(PKGPATH) tests/connecttwice.lua
+ $(LUA) $(PKGPATH) tests/exit.lua