aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-depgraph
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 08:23:28 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 08:56:47 -0300
commit9bf791620c6e57040860865d826923033e7fc179 (patch)
treee3fe10eb582f335ac59f3cb517b47f478b0eacb6 /community/lua-depgraph
parent370c61a9d7ca3f6b331c75e34cc2a71256d4eaf6 (diff)
downloadaports-9bf791620c6e57040860865d826923033e7fc179.tar.bz2
aports-9bf791620c6e57040860865d826923033e7fc179.tar.xz
community/lua-depgraph: enable luajit on s390x
Diffstat (limited to 'community/lua-depgraph')
-rw-r--r--community/lua-depgraph/APKBUILD14
1 files changed, 2 insertions, 12 deletions
diff --git a/community/lua-depgraph/APKBUILD b/community/lua-depgraph/APKBUILD
index 0a77c92f08..15e2fa2ef4 100644
--- a/community/lua-depgraph/APKBUILD
+++ b/community/lua-depgraph/APKBUILD
@@ -9,17 +9,10 @@ url="https://github.com/mpeterv/depgraph"
arch="noarch"
license="MIT"
depends="lua lua-argparse lua-filesystem"
-makedepends=""
-checkdepends="lua-busted"
+checkdepends="lua-busted luajit"
source="$pkgname-$pkgver.tar.gz::https://github.com/mpeterv/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-# luajit is not available for selected arches
-case "$CARCH" in
- s390x) _luajit="";;
- *) checkdepends="$checkdepends luajit" _luajit="jit";;
-esac
-
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
@@ -27,10 +20,9 @@ for _v in $_luaversions; do
done
check() {
- cd "$builddir"
mkdir -p .bin
- local lver; for lver in $_luaversions $_luajit; do
+ local lver; for lver in $_luaversions jit; do
msg "Testing on lua$lver"
ln -sf /usr/bin/lua$lver .bin/lua
@@ -41,8 +33,6 @@ check() {
}
package() {
- cd "$builddir"
-
install -m 755 -D bin/luadepgraph.lua "$pkgdir"/usr/bin/luadepgraph
}