diff options
author | Roberto Oliveira <robertoguimaraes8@gmail.com> | 2017-03-28 23:44:39 +0000 |
---|---|---|
committer | Jakub Jirutka <jakub@jirutka.cz> | 2017-03-29 12:42:00 +0200 |
commit | a73ecfc233bc38c7297e1feea5c3f47c53933958 (patch) | |
tree | 8ed89b7e32f9acb9bee110ce123391a358d71868 /community/lua-lpeg | |
parent | efa951e23fc789d7a44aeb0d194fd1bf83ded10d (diff) | |
download | aports-a73ecfc233bc38c7297e1feea5c3f47c53933958.tar.bz2 aports-a73ecfc233bc38c7297e1feea5c3f47c53933958.tar.xz |
community/lua-lpeg: update checksum
Review notes by @jirutka:
Upstream has republished the lpeg-1.0.1 tarball with two minor
modifications in file test.lua:
--- old/lpeg-1.0.1/test.lua
+++ new/lpeg-1.0.1/test.lua
@@ -1,6 +1,6 @@
#!/usr/bin/env lua
--- $Id: test.lua,v 1.111 2016/09/20 17:51:30 roberto Exp $
+-- $Id: test.lua,v 1.112 2017/01/14 18:55:22 roberto Exp $
-- require"strict" -- just to be pedantic
@@ -1132,7 +1132,7 @@
local function manyCmt (n)
return m.Cmt("a", function ()
local a = {}; for i = 1, n do a[i] = n - i end
- return true, table.unpack(a)
+ return true, unpack(a)
end)
end
@@ -1147,7 +1147,7 @@
-- bug in 1.0: problems with math-times returning too many captures
do
- local lim = 2^15 - 10
+ local lim = 2^11 - 10
local res = {m.match(manyCmt(lim), "a")}
assert(#res == lim and res[1] == lim - 1 and res[lim] == 0)
checkerr("too many", m.match, manyCmt(2^15), "a")
Diffstat (limited to 'community/lua-lpeg')
-rw-r--r-- | community/lua-lpeg/APKBUILD | 6 |
1 files changed, 2 insertions, 4 deletions
diff --git a/community/lua-lpeg/APKBUILD b/community/lua-lpeg/APKBUILD index 763cda08c4..afd28a4579 100644 --- a/community/lua-lpeg/APKBUILD +++ b/community/lua-lpeg/APKBUILD @@ -3,7 +3,7 @@ pkgname=lua-lpeg _pkgname=lpeg pkgver=1.0.1 -pkgrel=0 +pkgrel=1 pkgdesc="Pattern-matching library for Lua" url="http://www.inf.puc-rio.br/~roberto/lpeg" arch="all" @@ -59,6 +59,4 @@ _package() { "$subpkgdir"/usr/share/lua/$lver/re.lua || return 1 } -md5sums="52928c84a843eecbaa78c761cbcccc72 lpeg-1.0.1.tar.gz" -sha256sums="62006bcda4f73f0cd7a8164f9559397d4e928568fa55aa496cc8b861fb140fb3 lpeg-1.0.1.tar.gz" -sha512sums="680925ea539e4a5eb7508a0fb3cbc1ba3da51dced962ddf90714a700a7c3b3d5e062d5e0b5eb097ab74d5aee018cb1a831cb6247fac825f72ba071b76f896e5b lpeg-1.0.1.tar.gz" +sha512sums="7b43fbee7eff443000986684bc56bba6d2796a31cf860740746c70e155bdea1b62a46b93f97e2747e3ef0f63e965148778ac2985d0f2d83e1e37ec4ebbabf4aa lpeg-1.0.1.tar.gz" |