aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-lunix
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-12-26 11:16:33 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-12-26 11:19:05 +0100
commit377cf138a7135d5be50084b75bcc72ed210b210d (patch)
tree855777dec4f25a23a6c67a27cd76467a61dae442 /community/lua-lunix
parent4e07d3d6515a4984c6591d20f0480cff53364616 (diff)
downloadaports-377cf138a7135d5be50084b75bcc72ed210b210d.tar.bz2
aports-377cf138a7135d5be50084b75bcc72ed210b210d.tar.xz
community/lua-lunix: modernize abuild
Diffstat (limited to 'community/lua-lunix')
-rw-r--r--community/lua-lunix/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/community/lua-lunix/APKBUILD b/community/lua-lunix/APKBUILD
index 2933ea53c6..77609cdca8 100644
--- a/community/lua-lunix/APKBUILD
+++ b/community/lua-lunix/APKBUILD
@@ -16,15 +16,13 @@ for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
subpackages="$subpackages lua$_v-$_pkgname:_package"
done
-source="$pkgname-$pkgver.tar.gz::https://github.com/wahern/lunix/archive/rel-$pkgver.tar.gz"
+source="https://github.com/wahern/lunix/archive/rel-$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-rel-$pkgver"
build() {
- cd "$builddir"
-
local lver; for lver in $_luaversions; do
msg "Building for Lua $lver..."
- make all$lver || return 1
+ make all$lver
done
}