aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-mpack/dont-install-busted.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-18 15:19:55 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-18 15:24:04 +0100
commit40a9e74cb90d6994281f797a6712b3f766773566 (patch)
treeb89bc60518e55a1fd702c5727196069ade35f77a /community/lua-mpack/dont-install-busted.patch
parent28b4a4624b51bc62f94fbdeafecb01e3fe70aa9e (diff)
downloadaports-40a9e74cb90d6994281f797a6712b3f766773566.tar.bz2
aports-40a9e74cb90d6994281f797a6712b3f766773566.tar.xz
community/lua-mpack: fix test on lua5.3
Makefile tries to download and install LuaRocks to install busted and its dependencies. I workrounded this before, but somehow it now doesn't work for lua5.3, I have no clue why. Doesn't matter, just remove dependency on $(BUSTED) from the test target.
Diffstat (limited to 'community/lua-mpack/dont-install-busted.patch')
-rw-r--r--community/lua-mpack/dont-install-busted.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/lua-mpack/dont-install-busted.patch b/community/lua-mpack/dont-install-busted.patch
new file mode 100644
index 0000000000..f6e07fa28f
--- /dev/null
+++ b/community/lua-mpack/dont-install-busted.patch
@@ -0,0 +1,13 @@
+Fix Makefile to not try to download and install LuaRocks and busted; use
+system-provided busted.
+--- a/binding/lua/Makefile
++++ b/binding/lua/Makefile
+@@ -61,7 +61,7 @@
+ depsclean:
+ rm -rf $(DEPS_DIR)
+
+-test: $(BUSTED) $(MPACK)
++test: $(MPACK)
+ $(BUSTED) -o gtest test.lua
+
+ valgrind: $(BUSTED) $(MPACK)