aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-mpack
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-18 15:19:55 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-18 15:24:04 +0100
commit40a9e74cb90d6994281f797a6712b3f766773566 (patch)
treeb89bc60518e55a1fd702c5727196069ade35f77a /community/lua-mpack
parent28b4a4624b51bc62f94fbdeafecb01e3fe70aa9e (diff)
downloadaports-40a9e74cb90d6994281f797a6712b3f766773566.tar.bz2
aports-40a9e74cb90d6994281f797a6712b3f766773566.tar.xz
community/lua-mpack: fix test on lua5.3
Makefile tries to download and install LuaRocks to install busted and its dependencies. I workrounded this before, but somehow it now doesn't work for lua5.3, I have no clue why. Doesn't matter, just remove dependency on $(BUSTED) from the test target.
Diffstat (limited to 'community/lua-mpack')
-rw-r--r--community/lua-mpack/APKBUILD9
-rw-r--r--community/lua-mpack/dont-install-busted.patch13
2 files changed, 18 insertions, 4 deletions
diff --git a/community/lua-mpack/APKBUILD b/community/lua-mpack/APKBUILD
index 45bba241b8..6f258ab387 100644
--- a/community/lua-mpack/APKBUILD
+++ b/community/lua-mpack/APKBUILD
@@ -3,7 +3,7 @@
pkgname=lua-mpack
_pkgname=libmpack
pkgver=1.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Libmpack bindings for Lua"
url="https://github.com/tarruda/libmpack"
arch="all"
@@ -13,7 +13,8 @@ makedepends=""
checkdepends="lua-busted"
subpackages=""
source="$_pkgname-$pkgver.tar.gz::https://github.com/tarruda/$_pkgname/archive/$pkgver.tar.gz
- skip-memleak-test.patch"
+ skip-memleak-test.patch
+ dont-install-busted.patch"
builddir="$srcdir/$_pkgname-$pkgver"
_luaversions="5.1 5.2 5.3"
@@ -47,7 +48,6 @@ check() {
make -C "$builddir-$lver"/binding/lua \
USE_SYSTEM_LUA=yes \
LUA=/usr/bin/lua$lver \
- LUAROCKS=/bin/false \
BUSTED=/usr/bin/busted-$lver \
test || return 1
done
@@ -70,4 +70,5 @@ _subpackage() {
}
sha512sums="8e40a562faf8b62137dec0733cbb9006fa7054e5a47bdd128fb4dfd676fac4e4385a23c3d908a4ce2edd65d673db25916695fa74bc08c5316b0c80e571a7442c libmpack-1.0.4.tar.gz
-380603230e65b8b4adec0153aa23089612f0923666b44ca503a4217c1125c5f8cbac9eb550a94add8fa2d5ac40464689302c8e79e5a087f408707ae21eb9faa9 skip-memleak-test.patch"
+380603230e65b8b4adec0153aa23089612f0923666b44ca503a4217c1125c5f8cbac9eb550a94add8fa2d5ac40464689302c8e79e5a087f408707ae21eb9faa9 skip-memleak-test.patch
+a02076a3a5a98846ae5086f99b33655a7276087dc3ad0e0a64d742b1ca2de302a71ff173a555b9b33ac59f0d2837e5fdf64a3cccbe09791643d32b729bc04bee dont-install-busted.patch"
diff --git a/community/lua-mpack/dont-install-busted.patch b/community/lua-mpack/dont-install-busted.patch
new file mode 100644
index 0000000000..f6e07fa28f
--- /dev/null
+++ b/community/lua-mpack/dont-install-busted.patch
@@ -0,0 +1,13 @@
+Fix Makefile to not try to download and install LuaRocks and busted; use
+system-provided busted.
+--- a/binding/lua/Makefile
++++ b/binding/lua/Makefile
+@@ -61,7 +61,7 @@
+ depsclean:
+ rm -rf $(DEPS_DIR)
+
+-test: $(BUSTED) $(MPACK)
++test: $(MPACK)
+ $(BUSTED) -o gtest test.lua
+
+ valgrind: $(BUSTED) $(MPACK)