aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-turbo
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-11-07 20:32:30 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-11-08 08:38:02 +0000
commit6f346d05cc2c82753591fb653bd837913d9b11b6 (patch)
tree15e99cdfe8f19b2b5efaf1d7d54101d1edfea97f /community/lua-turbo
parent450e40ca331bb6953e36a33bbea53c13a2e03cd0 (diff)
downloadaports-6f346d05cc2c82753591fb653bd837913d9b11b6.tar.bz2
aports-6f346d05cc2c82753591fb653bd837913d9b11b6.tar.xz
community/lua-turbo: fix ssl loading
Diffstat (limited to 'community/lua-turbo')
-rw-r--r--community/lua-turbo/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/community/lua-turbo/APKBUILD b/community/lua-turbo/APKBUILD
index 5ed2a2a182..cb3961c002 100644
--- a/community/lua-turbo/APKBUILD
+++ b/community/lua-turbo/APKBUILD
@@ -4,7 +4,7 @@
pkgname=lua-turbo
_jitver=2.1.0_beta3
pkgver=2.1.3
-pkgrel=0
+pkgrel=1
pkgdesc="a framework built for LuaJIT 2 and Linux"
url="https://github.com/kernelsauce/turbo"
# luajit is not available for disabled arches
@@ -36,12 +36,11 @@ prepare() {
die "cannot locate luajit APKBUILD!"
fi
# we need to fix the loading of libssl.
- # so we replace symlink with real filename
sed -i -e \
- "s|os.getenv(\"TURBO_LIBSSL\") or \"ssl\"|\"$(readlink /lib/libssl.so.47)\"|" \
+ 's|"ssl")$|"/lib/libssl.so.47")|' \
turbo/hash.lua
sed -i -e \
- "s|os.getenv(\"TURBO_LIBSSL\") or \"ssl\"|\"$(readlink /lib/libssl.so.47)\"|" \
+ 's|"ssl")$|"/lib/libssl.so.47")|' \
turbo/crypto_linux.lua
}