aboutsummaryrefslogtreecommitdiffstats
path: root/community/luarocks
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-01-02 16:30:12 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-01-02 16:32:18 +0100
commita9385ec5f251958a00ec8f2651d2d857b6118c38 (patch)
treec5e14c8f8a3601ec67a7b5a9ede45f6ea6690045 /community/luarocks
parentde00305709cc9c7b5db5e6b64750cd84c3b96f99 (diff)
downloadaports-a9385ec5f251958a00ec8f2651d2d857b6118c38.tar.bz2
aports-a9385ec5f251958a00ec8f2651d2d857b6118c38.tar.xz
community/luarocks: triggeres should not be defined in split func
However, this does not solve the problem that trigger is not triggered when a Lua module is uninstalled (i.e. rock's directory inside the watched directory is deleted).
Diffstat (limited to 'community/luarocks')
-rw-r--r--community/luarocks/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/community/luarocks/APKBUILD b/community/luarocks/APKBUILD
index 2ec621c665..bce6f78398 100644
--- a/community/luarocks/APKBUILD
+++ b/community/luarocks/APKBUILD
@@ -20,6 +20,7 @@ _lua_versions="5.1 5.2 5.3"
for _v in $_lua_versions; do
makedepends="$makedepends lua$_v-dev"
subpackages="$subpackages $pkgname${_v}:_subpackage"
+ triggers="$triggers $pkgname$_v.trigger=/usr/lib/luarocks/rocks-$_v:/usr/lib/luarocks/rocks-common"
done
prepare() {
@@ -60,7 +61,6 @@ _subpackage() {
pkgdesc="Deployment and management system for Lua $lver modules"
install_if="lua$lver $pkgname=$pkgver-r$pkgrel"
depends="lua$lver"
- triggers="$subpkgname.trigger=/usr/lib/luarocks/rocks-$lver/*:/usr/lib/luarocks/rocks-common/*"
cd "$builddir-$lver"